Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 05-01-2013, 10:38 PM
livid livid is offline
TT Newbie
 
Join Date: Apr 2013
Boat: Mastercraft Maristar 245 2005 8.1L Crusader
Location: Midwest
Posts: 6
Flashing "ECU" trouble? 05 245

I purchased a 2005 Maristar 245 with 51 hours about 2 months ago. I test drove the boat the day I purchased it and once a few weeks before and it ran great. When I got it home, it had to sit for 3 weeks due to the weather being cold.

So the first warm day, I took it to the water. When I tried to start it, it would not start and the display started flashing "ECU". I went home, did some research and saw it might be a ground connection, so I cleaned and tightened every wire i could find as well as check every visible fuse. Replaced the safety switch, switched the batteries. I've spent roughly 4 days after work in the boat cleaning connections and double checking things. And right now the dealer says they are 2 months out on taking a look at it.

Symptoms:
When I turn the key to on, the gauges make the winding sound, but none display any data. After about 30 seconds the display screen starts flashing "ECU". When I try to start it, it sounds just like the safety lanyard is off (Like no fire). I don't think I hear the fuel pump wind up (hard to tell) but I press the plug on the fuel rails and gas comes out so it seems to be pressurized with fuel. 8.1L Crusader w/ 51 hours. No perfect pass.

I'm starting to really think it may be the MMDC or ECU??? Is their anything that I may have missed?
__________________
Wake, Lake, and Summer Apparel
www.lividclothing.com
Reply With Quote
  #2  
Old 05-02-2013, 09:38 AM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,101
Have you check for trouble codes?
__________________
Tim
Gone, surfing.
Reply With Quote
  #3  
Old 05-02-2013, 10:18 AM
livid livid is offline
TT Newbie
 
Join Date: Apr 2013
Boat: Mastercraft Maristar 245 2005 8.1L Crusader
Location: Midwest
Posts: 6
Actually I stumbled across a thread you posted on in 2011 last night.... About jumping the A and B terminals on the DLC and using an LED light. I plan on trying this today after work.
Attached Images
 
__________________
Wake, Lake, and Summer Apparel
www.lividclothing.com
Reply With Quote
  #4  
Old 05-02-2013, 10:23 AM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,101
You may be able to read the codes by putting the ECM into diagnostic mode and reading the ECU flashes. Using an LED takes a bit more work as that thread explains. It's not just an LED with a couple of wires attached to it.

But, since you found that thread you are on your way. Let us know if you have questions.
__________________
Tim
Gone, surfing.
Reply With Quote
  #5  
Old 05-02-2013, 11:04 AM
rgardjr1's Avatar
rgardjr1 rgardjr1 is offline
MC Fanatic
 
Join Date: Oct 2008
Boat: Mastercraft, Maristar 200 SS, 2006, 5.7L Crusader
Location: Liberty Lake, WA
Posts: 960
Make sure your battery is fully charged. I will get a "BAD ECU" in the display and no gauges when I've run down my battery. My Perfect Pass gauge will still work though. My boat starts just fine when this happens.
__________________
2006 Maristar 200 SS
Reply With Quote
  #6  
Old 08-19-2013, 04:59 PM
michael79 michael79 is offline
TT Newbie
 
Join Date: Aug 2013
Boat: 2005 prostart V
Location: Southeast
Posts: 15
Livid,
Any insights you can share on your problem?
Reply With Quote
  #7  
Old 09-14-2013, 09:13 AM
Topp dawg Topp dawg is offline
TT Enthusiast
 
Join Date: Jun 2013
Boat: 2003 Mastercraft X10
Location: Southeast
Posts: 190
How cani tell if i can use that procedure on my engine? I have a 2003 x10.
Reply With Quote
  #8  
Old 09-14-2013, 09:42 AM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,101
Quote:
Originally Posted by Topp dawg View Post
How cani tell if i can use that procedure on my engine? I have a 2003 x10.
You boat does have an ECM but I'm not sure which one. You should be able to use that other thread to pull codes. Look for your DLC back near the engine.
__________________
Tim
Gone, surfing.
Reply With Quote
Reply

Tags
ecu, gauges, maristar, mmdc

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 07:13 AM.