Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 02-26-2013, 05:30 AM
youngman youngman is offline
TT Newbie
 
Join Date: May 2011
Boat: Mastercraft, prostar 190, 1994, 350 indmar TBI
Location: australia
Posts: 8
Do I need a new throttle cable?

Hi, own a 1994 prostar 190. When I move the throttle lever forward it goes into gear as normal, but when I try to accelerate up to speed nothing happens until the lever is almost as far as it goes. In this position the boat would normally be doing about 44mph but now is only doing about 20mph. Everything looks ok behind the lever beside the drivers seat. Has this happened to anyone, or any ideas on what I should be looking for. Much appreciated.
Reply With Quote
  #2  
Old 02-26-2013, 07:45 AM
mayo93prostar mayo93prostar is offline
MC Fanatic
 
Join Date: Dec 2004
Boat: 1993 Prostar 190 Blue Stars and Stripes, Powerslot
Location: Annapolis, MD
Posts: 769
Sounds like your throttle cable may have come loose at the "carb". Check that first. Second is to check the cable connection behind the throttle lever. If it is moving some, I doubt you need a new cable but you may. I assume you have fuel injection in a 94.
__________________
1993 Blue Stars and Stripes Prostar Powerslot 351HO
Mastercraft: Face It - If you are not a good skier behind this boat, you are not a good skier.
Reply With Quote
  #3  
Old 02-26-2013, 03:42 PM
Shooter McKevin's Avatar
Shooter McKevin Shooter McKevin is offline
TT Enthusiast
 
Join Date: Mar 2010
Boat: 2000 Prostar 190, LTR 330
Location: Calgary Canada
Posts: 366
If you have perfect pass then I'd say it's the tension knob (or whatever perfect pass calls it). Mine does that occasionally and the knob needs to be re-wound manually.
Reply With Quote
  #4  
Old 02-26-2013, 04:46 PM
TxsRiverRat's Avatar
TxsRiverRat TxsRiverRat is offline
MC Maniac
 
Join Date: May 2011
Boat: 93 Prostar 205
Location: Southwest
Posts: 3,264
I had the same issue in 2012, we replaced a little piece in the throttle assembly itself... I'm not sure what it's called... Jeff Knight @ Texas Mastercraft will know what you need and what it's called. My throttle is perfect now.
__________________
What does the fox say?

Ring-ding-ding-ding-dingeringeding...

You know they all have a little string hanging out, but it's not a tampon, it's a price tag...
Reply With Quote
  #5  
Old 04-29-2013, 05:50 PM
Epimetheus Epimetheus is offline
TT Newbie
 
Join Date: Apr 2013
Boat: Mastercraft prostar 190 1996
Location: England
Posts: 7
Update?

Did you get to the bottom of this? I have the same problem and I figure the cable is stretched. I adjusted it as far as I could but wasn't enough. So I figure a new cable will be the fix?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:40 PM.