Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 04-28-2013, 11:49 AM
h2oskifreak's Avatar
h2oskifreak h2oskifreak is offline
MC Devotee
 
Join Date: May 2007
Boat: 1994 PS 190 TBI
Location: West
Posts: 1,227
94 ps 190 start issue

First day out was not what I was hoping for. Dunked her with what I thought was a freshly charged 2 year old Interstate Marine battery and only a soft click. I was getting power but not enough to do much other than hear a fuel injector and the aforementioned soft click, not the starter engaging at all. So, my thought goes to bad battery. Brought it home and put in a battery that came out of a 75 MC (that turned and ran yesterday with this battery). Same issue/sound. This time I did think to check other things like radio and I have power there. Next thought, could it be a fuse. I pulled the dash fuse area and was not expecting to see what I did. Are these special fuses, or just hidden under the metal looking shield/box? Am I on the right track, maybe Motor fuse mentioned on back of engine? What other suggestions plesae, I am ready to ski and my ride isn't. Thanks
__________________
"One foot in the grave, one foot on the pedal, I was born a rebel" Petty
Reply With Quote
  #2  
Old 04-28-2013, 11:59 AM
Kyle's Avatar
Kyle Kyle is offline
MC Maniac
 
Join Date: Jan 2007
Boat: 93 Prostar 190
Location: Fort Worth, TEXAS
Posts: 3,240
I would check the starter.

Check where the + and - connect. Is the ground good and tight on the bell housing.

Take a hammer and tap with some authority (not beat on or tear up) the casing of the starter. Then try to start it.


I'm guessing the starter is bad. The click is the starter solenoid trying to enguage the starter. I'm sure the armature is rusty or has bad spots.
__________________
Rollin' Gangsta Style

Quote:
Originally Posted by Thrall View Post
"Heavy" beer is for wine drinkers that are too embarrassed to drink wine in front of their buddies. "Light" beer is a drinkin' man's beer!
Quote:
Originally Posted by thatsmrmastercraft View Post
If you want bling like the big dawgs, ya gotta lift your leg a little higher.....
Reply With Quote
  #3  
Old 04-28-2013, 12:15 PM
h2oskifreak's Avatar
h2oskifreak h2oskifreak is offline
MC Devotee
 
Join Date: May 2007
Boat: 1994 PS 190 TBI
Location: West
Posts: 1,227
I am hoping the starter is not bad as it was replaced by PO 2 years ago. I have the fake a lake hooked up so later today I will try what you suggested with the starter. Thank you.
__________________
"One foot in the grave, one foot on the pedal, I was born a rebel" Petty
Reply With Quote
  #4  
Old 04-28-2013, 12:55 PM
h2oskifreak's Avatar
h2oskifreak h2oskifreak is offline
MC Devotee
 
Join Date: May 2007
Boat: 1994 PS 190 TBI
Location: West
Posts: 1,227
Kyle, You Da Man! Sweet Fancy Moses, she is ALIVE! Few taps on the starter and my ski season begins. 61 degree water yesterday. Thanks, my attitude is dramatically better...matter of fact my wife just suggested Hooters for lunch. Today, much better than yesterday.
__________________
"One foot in the grave, one foot on the pedal, I was born a rebel" Petty
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:41 PM.