Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Restorations and Refurbishments

Reply
 
Thread Tools Display Modes
  #51  
Old 04-22-2013, 09:41 PM
wheelerd's Avatar
wheelerd wheelerd is offline
MC Fanatic
 
Join Date: Dec 2007
Boat: 2005 X2
Location: Central Alberta, Canada
Posts: 911
How did you "mess up" the decal install?
(Not a condescending question - just wondering what you think you did wrong.)
__________________
"For every complex problem there is an answer that is clear, simple, and wrong." (Henry Louis Mencken)
2005 X2, Viper Red, MCX, Acme 1285, PPass, rear 750 sacs, KGB, IBS, Bennett Wake Plate
(previous) 2001 X5, 1991 TriStar 190
Reply With Quote
  #52  
Old 04-22-2013, 10:16 PM
lakeoz tristar's Avatar
lakeoz tristar lakeoz tristar is offline
TT Enthusiast
 
Join Date: May 2012
Boat: 1990 Tristar 190 and 1998 Baha Cruiser Mach 1 290
Location: KC/Lake OZ-- Lincoln Park Mich Native
Posts: 134
Mostly tried to rush it.. Had the boat on the drive way the side that is all blocked in.>thought I could do that side outside and finish the other side up while back in the garage.. And the crazy part was its not like I was going to take it out anytime soon after that..so yeah I still have the other side but that one got buggered up pretty bad..Tried to do it slow and i figured out it wasn't something I have done with out a helper and had much better results.
Reply With Quote
  #53  
Old 07-18-2013, 12:13 PM
Jaxon4's Avatar
Jaxon4 Jaxon4 is offline
TT Regular
 
Join Date: Jul 2012
Boat: 1989 Tristar 190
Location: Midwest
Posts: 54
chrome air exhaust vents

Quote:
Originally Posted by lakeoz tristar View Post
Wish I had a better picture (driver side rear corner red showing through right at the edge) but I had a pretty bad spot from the previous owner so I thought what the heck I can fix that or at least try to fix it.. My real problem is that I think there was repairs made at some point to this boat either with get coat, paint or just fading because there are color variations all over, Might just be the age of the boat and patterns of fading from the sun, not really sure..Some areas are a real dull grey and others are white in contrast... Regardless I was trying to patch this are.. I sanded down the rough edges and a bit further out into the gel coat and filled with evercoat formula 27 that made it looked better than it was.. After sanding that all down I started the next step applying Evercoat Polyester Gel Paste #100695.. The first batch never set it was either too cold or not enough hardener.. Second batch set up fine, The problem with this batch was that the PVA release agent when I sprayed it on it was in too powerful spray bottle so it basically cut right through the gel coat and made a mess. Cleaned all that out before it set.. Now round three, didn't have access to another spray bottle so I covered this set up with cling wrap.. Set up fine only problem was that it looked horrible once dried looked like a brain or worm trails all through it.. That coat set up so basically I had to sand that all off so I am at square one.. I read all the posts I could find on here.. If any one has any suggestions at my next attempt I am glad to hear them..

My next thought was to get the preval spray and thin this down and try to spray it on this time and use another preval sprayer to apply the PVA release agent..Any thoughts if this is the right route to go? Also I wanted to work on some other dinged up areas once I can get this fixed up, spider cracks on the swim deck, also want to get practice as there is a spot on my other boat I need to repair..
Where did you get the chrome air exhaust vents...like the look....btw boat looks great!
I own a Tristar as well..1989...love it!! Great boat!!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:17 AM.