Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

Reply
 
Thread Tools Display Modes
  #1  
Old 02-27-2013, 10:24 AM
WC205's Avatar
WC205 WC205 is offline
TT Regular
 
Join Date: Feb 2013
Boat: 2004 Prostar205v
Location: Midwest
Posts: 42
Bilge Pump Replacement

Need to replace the center bilge pump on my 2004 Prostar 205V. It will run but won't actually pump any water. Below is what I have now. Wondering if the one in the link is the correct replacement. Also hoping that I can just unplug the old and then clip the wiring right into the new.

http://www.overtons.com/modperl/prod...view&from=grid
Attached Images
 
Reply With Quote
  #2  
Old 02-27-2013, 11:02 AM
Lumbergh's Avatar
Lumbergh Lumbergh is offline
MC Fanatic
 
Join Date: Aug 2011
Boat: 1991 ProStar 190
Location: Seattle
Posts: 733
Amazon sells a variety of bilge pumps.

Usually the best prices as well.

Worst case, clip wires and install new pump.

Easy project, sometimes tight quarters but nothing to worry about.
__________________
1991 ProStar / 351W with 1:1 Velvet Drive
Reply With Quote
  #3  
Old 02-27-2013, 11:05 AM
Table Rocker's Avatar
Table Rocker Table Rocker is offline
MC Devotee
 
Join Date: Oct 2010
Boat: '96 ProStar 205, Sammy Duvall, LT-1
Location: Fayetteville, Arkansas
Posts: 1,578
If it will run, you might take it apart. There is an impeller in there that might be full of carpet fibers and sludge. If you break it, you haven't really lost anything.
__________________
'96 ProStar 205 SD LT-1
Reply With Quote
  #4  
Old 02-27-2013, 11:24 AM
Table Rocker's Avatar
Table Rocker Table Rocker is offline
MC Devotee
 
Join Date: Oct 2010
Boat: '96 ProStar 205, Sammy Duvall, LT-1
Location: Fayetteville, Arkansas
Posts: 1,578
Here are some instructions:
Attached Images
File Type: pdf iinstr_rm_500_750_1100.pdf (350.2 KB, 2052 views)
__________________
'96 ProStar 205 SD LT-1
Reply With Quote
  #5  
Old 02-27-2013, 11:27 AM
rgardjr1's Avatar
rgardjr1 rgardjr1 is offline
MC Fanatic
 
Join Date: Oct 2008
Boat: Mastercraft, Maristar 200 SS, 2006, 5.7L Crusader
Location: Liberty Lake, WA
Posts: 960
When I replace mine a couple of years ago I was able to find and exact replacement on Ebay. The basket that the pump mounts to on the bottom of the boat may not be the same-pull yours out and see if you can tell compared to the picture on the Overton's page.
__________________
2006 Maristar 200 SS
Reply With Quote
  #6  
Old 02-27-2013, 11:31 AM
WC205's Avatar
WC205 WC205 is offline
TT Regular
 
Join Date: Feb 2013
Boat: 2004 Prostar205v
Location: Midwest
Posts: 42
Awesome. I'll check it out before I buy anything. Thanks.
Reply With Quote
  #7  
Old 02-27-2013, 11:40 AM
Table Rocker's Avatar
Table Rocker Table Rocker is offline
MC Devotee
 
Join Date: Oct 2010
Boat: '96 ProStar 205, Sammy Duvall, LT-1
Location: Fayetteville, Arkansas
Posts: 1,578
Quote:
Originally Posted by WC205 View Post
Awesome. I'll check it out before I buy anything. Thanks.
Glad to help, let us know how it goes.
__________________
'96 ProStar 205 SD LT-1
Reply With Quote
  #8  
Old 02-27-2013, 02:07 PM
rgardjr1's Avatar
rgardjr1 rgardjr1 is offline
MC Fanatic
 
Join Date: Oct 2008
Boat: Mastercraft, Maristar 200 SS, 2006, 5.7L Crusader
Location: Liberty Lake, WA
Posts: 960
If you do end up needing one I saw this one on Ebay that was the older version:
http://www.ebay.com/itm/370765432870
Once you pull yours out to see if you can get it pumping you'll be able to tell if this one would be a direct replacement.
__________________
2006 Maristar 200 SS
Reply With Quote
  #9  
Old 04-18-2013, 05:57 PM
WC205's Avatar
WC205 WC205 is offline
TT Regular
 
Join Date: Feb 2013
Boat: 2004 Prostar205v
Location: Midwest
Posts: 42
Quote:
Originally Posted by Table Rocker View Post
Glad to help, let us know how it goes.
You were right. Just full of filth muck in there. Cleaned it out and it pumped. You saved me some cash so THANKS!!
Reply With Quote
  #10  
Old 04-18-2013, 05:58 PM
Table Rocker's Avatar
Table Rocker Table Rocker is offline
MC Devotee
 
Join Date: Oct 2010
Boat: '96 ProStar 205, Sammy Duvall, LT-1
Location: Fayetteville, Arkansas
Posts: 1,578
Quote:
Originally Posted by WC205 View Post
You were right. Just full of filth muck in there. Cleaned it out and it pumped. You saved me some cash so THANKS!!
I'm glad it worked out. Thanks for the update.
__________________
'96 ProStar 205 SD LT-1
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:32 AM.