Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #31  
Old 04-01-2013, 12:55 AM
Mark rsa2au's Avatar
Mark rsa2au Mark rsa2au is offline
TT Enthusiast
 
Join Date: Mar 2013
Boat: Mastercraft X5 2001. 310hp preditor
Location: Australia
Posts: 182
Quote:
Originally Posted by JimN View Post
The 1.1 Ohms is high. Get the resistors and substitute them for the ECT, as I posted. If the check engine light goes off when you disconnect it, it has a problem (or, the plug/wires on its harness). The sensor going to the gauge has nothing to do with what's going to the ECM.

44 may be IC module- contact Mastercraft or Indmar and ask them about it- my manual isn't here at the moment, so I can't check this.

Disconnect the battery, let it sit for a few minutes and remove the plugs from the ECM. Open the plastic shell and look for the black wires and measure from the ECM plug to the battery posts, not the terminals. The resistance between the terminal and post can be enough to cause problems.

Here's a manual for MEFI 4, but it's not exactly for your engine. The pin out,, diagrams and diagnostics are basically the same. You'll notice that the MAP sensor is different (the one in the link is like the one on the LTR. MCX and some of the others that aren't TBI).

http://www.pirate4x4.com/tech/billav...510005P%29.pdf
Thanks JimN,

I now have the boat parked for a while, hit a rock in 7 feet of water....... buggered the prop, shaft, strut, and log....
Then found the fiberglass repair on the exhaust had blown off with one of the backfires and had filled the bilge..... because the auto function of the bilge pump is not working.

Will check the earth resistance etc when I feel like looking at it again.

On the bright side the over fueling and running rich seems to have stopped.
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:53 AM.