Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #61  
Old 02-26-2013, 02:21 PM
Stefan's Avatar
Stefan Stefan is offline
TT Enthusiast
 
Join Date: Apr 2012
Boat: 2012 X-15...gone, 2014 X-46 Gen2+
Location: middle of Germany, center of Europe (the old world)
Posts: 387
We'd probably have to find somebody in the southern U.S. or the southern Hemisphere around this time of year...
__________________
If You Find To Many Capitals You Can Keep Them...I'm German
Reply With Quote
  #62  
Old 02-26-2013, 03:00 PM
Mastercraftdave's Avatar
Mastercraftdave Mastercraftdave is offline
TT Enthusiast
 
Join Date: Feb 2012
Boat: Mastercraft x45
Location: Southeast
Posts: 278
Quote:
Originally Posted by CBRENT View Post
Is no one running the latest update that is supposed to fix everything?
I went and checked out my boat at the dealer after they had added the new software and everything seemed to work. I didnt get to try the ballast but all of the radio funtions worked and the screeen switched through with no glitches. the PnP ballast even seemed to work alittle bit better. I should get it back soon but initial testing showed that it worked... For now....
__________________
Reply With Quote
  #63  
Old 02-26-2013, 03:10 PM
CBRENT's Avatar
CBRENT CBRENT is offline
TT Enthusiast
 
Join Date: May 2010
Boat: 2012 X2
Location: Midwest
Posts: 282
This is good news! Let's hope the ballast is fixed too. I'm about a month away on getting mine back into the water. Excited to have everything working as promised, maybe...
Reply With Quote
  #64  
Old 02-26-2013, 03:17 PM
Mastercraftdave's Avatar
Mastercraftdave Mastercraftdave is offline
TT Enthusiast
 
Join Date: Feb 2012
Boat: Mastercraft x45
Location: Southeast
Posts: 278
Quote:
Originally Posted by CBRENT View Post
This is good news! Let's hope the ballast is fixed too. I'm about a month away on getting mine back into the water. Excited to have everything working as promised, maybe...
My PnP ballast switched from tanks to bags and back to tanks just fine. It is my understand that they redid the valaves that switched to bags and used a new mounting spot atleast this is what my dealer said. Also he said that the timers for the bags have been switched to 750 lbs bags. I curiuos to see if this actually works.... There maybe hope...
__________________
Reply With Quote
  #65  
Old 02-27-2013, 02:43 PM
Aric'sX15's Avatar
Aric'sX15 Aric'sX15 is online now
MC Maniac
 
Join Date: Nov 2007
Boat: Mainship Pilot 30
Location: Corinth
Posts: 3,059
So on the pnp ballast, it's not just over flow from the hard tanks?
__________________
"if one day the speed kills me, do not cry because i was smiling." -Paul Walker
Reply With Quote
  #66  
Old 02-28-2013, 10:18 AM
bcd bcd is offline
TT Enthusiast
 
Join Date: Jul 2011
Boat: 93 Larson 200 SEI, 2002 X Star, 2012 X-2
Location: Dubuque, IA
Posts: 388
Quote:
Originally Posted by Aric'sX15 View Post
So on the pnp ballast, it's not just over flow from the hard tanks?
Not sure what changed for 2013, but in 2012, no it's not just over flow. For each pump, there is a motor that turns a directional valve to switch between the hard tanks and bags so you only fill/empty one or the other at a time.
Reply With Quote
  #67  
Old 02-28-2013, 12:12 PM
KahunaCraft's Avatar
KahunaCraft KahunaCraft is offline
TT Enthusiast
 
Join Date: Oct 2012
Boat: 2012 X30, 6L
Location: Canada
Posts: 412
2012 Touchscreen Issues!!!!!

For me, I don't have the PnP bags, I've piggy backed 1100#ers off of the stock rear hard tanks + I added a super sacr to double fill the bigger bags. The overflow connected to the top of these bags feeds to one-way check-valve then to the side of the boat thru-hull.

From what I understand, the extra bags in my scenario will fill using the new 'timer like' adjustment in the new software upgrade.

In 8-9 weeks, I'll post my tests of the new system.
Reply With Quote
  #68  
Old 03-19-2013, 09:34 AM
bcd bcd is offline
TT Enthusiast
 
Join Date: Jul 2011
Boat: 93 Larson 200 SEI, 2002 X Star, 2012 X-2
Location: Dubuque, IA
Posts: 388
I'm getting ready to bring my boat in for the software updates. I had some questions about my boat issues, so I called MC. They told me that the new software updates will not allow the dealer to adjust fill times. He said there were discussions about it, but it was not implemented.

KahunaCraft, has your dealer already installed the update and done this adjustment?
Reply With Quote
  #69  
Old 03-19-2013, 05:36 PM
Mastercraftdave's Avatar
Mastercraftdave Mastercraftdave is offline
TT Enthusiast
 
Join Date: Feb 2012
Boat: Mastercraft x45
Location: Southeast
Posts: 278
Quote:
Originally Posted by bcd View Post
I'm getting ready to bring my boat in for the software updates. I had some questions about my boat issues, so I called MC. They told me that the new software updates will not allow the dealer to adjust fill times. He said there were discussions about it, but it was not implemented.

KahunaCraft, has your dealer already installed the update and done this adjustment?
This is news to me I was told by my dealer that they were now set to the 750 for my rears. However this is coming from the dealer that has had my boat for 3 months and is still some how not finished so im not really sure if it works or not but im crossing my finigers and praying to God that its finished for this weeknd. The weather is in the high 70's here and im ready to be on the water.
__________________
Reply With Quote
  #70  
Old 03-19-2013, 08:17 PM
KahunaCraft's Avatar
KahunaCraft KahunaCraft is offline
TT Enthusiast
 
Join Date: Oct 2012
Boat: 2012 X30, 6L
Location: Canada
Posts: 412
My information came direct from the technical product prime at MC during face to face meeting specifically targeted to address the issues with the software. He gave me the specifics on what I've posted here.

Subsequently, my dealer has installed the piggy backs and is in the middle of the software upgrade. I say in the middle because it is a two step process. Step 1 was to load the software and configuration with additional timing parameters via a tool the dealer has to buy from Medallion through MC, that part has been done (I believe, but don't have 100% confirmation) . Then step 2, where they need to bring the engine up to a certain (3500-4200?) RPM for X (30?) seconds to calibrate. I'm wondering if your dealer just didn't buy the tool.

I'm about 4-5 weeks away from testing, but that will depend on the speed the ice gets out of the lake.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:06 AM.