Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Audio/Stereo

Reply
 
Thread Tools Display Modes
  #1  
Old 02-14-2013, 11:05 PM
Meeker Meeker is offline
TT Enthusiast
 
Join Date: Sep 2011
Boat: 05 X45
Location: Rockies
Posts: 120
X45 Stereo and Battery Setup

Going from 04 X30 to 05 X45. On my 30 I had a three battery setup. One engine battery and two stereo batteries. I had the Borg Warner relay where the stereo would run off the two batteries when parked and charging when boat was running. The engine battery was in the back stock location and the two optima blue tops for the stereo where under the observers seat area. I had heavy gauge welding cable running from the engine battery to the stereo batteries. It worked very well, no switches to remember to turn and boat always started with no battery issues.

Just wondering what setup to go with in the 45. I will be running three amps for the stereo. The X45 already has a guest battery switch and battery isolator. Should I run the switch and isolator with the three batteries or go back to the Borg Warner relay?

Also, I would like to put all three batteries in back stock compartment. I would plan on running heavy duty cable up to the observers seat area where the amps are mounted and do fused distribution blocks to the amps.

Anyone have pics and info on there X45 stereo setup?

Thanks
Reply With Quote
  #2  
Old 02-19-2013, 02:13 PM
Ckrbjohn Ckrbjohn is offline
TT Newbie
 
Join Date: Feb 2013
Boat: 2007 x45 8.1
Location: Northwest
Posts: 19
Just bought an 07 x45 2 months ago... Ended up buying a interstate marine 4D battery... 219 $$ and it fits along side the two other cranking interstates that are turned length wise in the existing trays...
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:25 AM.