Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #11  
Old 02-18-2013, 01:25 AM
kgrove kgrove is offline
MC Fanatic
 
Join Date: Jun 2008
Boat: 2011 X-25
Location: Phoenix
Posts: 548
Resurrecting this thread as I was using it to try and fix a problem...

I've been having problems with my Perfect Pass Wakeboard Pro on my '08 X-15 surging and/or slowing way down when I hit rollers, especially if it is multiple rollers when a couple boats pass. I went to play with the settings as suggested above to see if that would fix it and got confused. At least in wakeboard mode, mine only has KDW and not CS or NN settings. Are these other two in a different menu somewhere? Or in a mode other than wakeboard mode? Or is there a firmware update that I missed somewhere? Looking at the instructions in the pdf earlier in this thread, I've never seen that screen with CS and NN. Mine goes straight to the named riders list where only KDW is available.

If I can't get this sucker working better, I may fork out the $500 and upgrade to Stargazer so I can bypass the paddle wheel driven problems.
Reply With Quote
  #12  
Old 02-18-2013, 11:44 AM
GoneBoatN's Avatar
GoneBoatN GoneBoatN is online now
MC Devotee
 
Join Date: Oct 2010
Boat: 2010 X-15 w/MCX
Location: Nor Cal
Posts: 1,486
Quote:
Originally Posted by kgrove View Post
Resurrecting this thread as I was using it to try and fix a problem...

I've been having problems with my Perfect Pass Wakeboard Pro on my '08 X-15 surging and/or slowing way down when I hit rollers, especially if it is multiple rollers when a couple boats pass. I went to play with the settings as suggested above to see if that would fix it and got confused. At least in wakeboard mode, mine only has KDW and not CS or NN settings. Are these other two in a different menu somewhere? Or in a mode other than wakeboard mode? Or is there a firmware update that I missed somewhere? Looking at the instructions in the pdf earlier in this thread, I've never seen that screen with CS and NN. Mine goes straight to the named riders list where only KDW is available.

If I can't get this sucker working better, I may fork out the $500 and upgrade to Stargazer so I can bypass the paddle wheel driven problems.
Did you see pages 3-5 of the manual I attached in post #4 of this thread? I don't know if that document describes your gauges/controls or not.

If your X-15 has the paddle wheel mounted the same as mine, the issue is where it is located on the hull. I was told this by the people at PP when I contacted them for guidance on the settings. Mine is by the center drain plug of the boat. So when going through rollers it is actually leaving the water and catching air. The folks at PP said it really should be more towards the stern to keep it from doing that. For me, increasing the filter factor (NN) helped reduce the issue drastically. It does however take a bit more time for the boat to settle into the correct speed.

You most likely know this. But my son would only advance the throttle to where the PP engaged. So when the boat needed to use more throttle it was not able to. I have to remind him to move the throttle a little extra forward.
Reply With Quote
  #13  
Old 02-18-2013, 02:29 PM
kgrove kgrove is offline
MC Fanatic
 
Join Date: Jun 2008
Boat: 2011 X-25
Location: Phoenix
Posts: 548
I never saw those screens on my PP. On mine you only choose the mode when creating a new named rider, and when you choose wakeboard mode it only displays an option for KDW. Maybe it's buried in a menu somewhere. Or maybe once you have named rider lists you lose the ability to set NN and CS.

I need to go out one night where I can spend more time with it. Im usually monkeying with it on the water while somebody is waiting for me to be ready and I'm going from memory and don't have this forum or that PDF in front of me. If I can't find those settings in another menu, I'll try a factory reset and start for scratch.

My paddle wheel is indeed near the center drain plug. I used to never have a problem with this and initially suspected something was wrong with my paddle wheel (still possible). I think what's happened, however is that I've recently been riding with better riders who want the boat going a little faster. At 22mph and below I'm thinking that paddle wheel was less likely to come out even going through rollers, but at 23-24 it's causing much more of a problem. Hopefully I can correct this with settings. I don't want to spend the money on a Stargazer upgrade.

Last edited by kgrove; 02-18-2013 at 08:37 PM.
Reply With Quote
  #14  
Old 02-18-2013, 03:55 PM
CC2MC's Avatar
CC2MC CC2MC is offline
MC Fanatic
 
Join Date: Aug 2012
Boat: 2003 Maristar 210 Predator
Location: Alabama
Posts: 948
I am having some of the same issues. I am not even using the specified user settings bc mine was so bad. I messed with all the numbers with a little change, but I mostly just use the RPM mode now. I am going to try some of the numbers in this thread to see if a combination of them will help the problem. I have yet to try it with ballast in the boat so that may make it even more of a headache. Only a few more weeks until I can throw the boat in the water.
Reply With Quote
  #15  
Old 07-01-2013, 08:38 AM
StarLake StarLake is online now
TT Newbie
 
Join Date: Jan 2013
Boat: 99 mastercraft maristar 210 vrs
Location: midwest
Posts: 7
2012 X2 settings

Does anyone have the settings for an x2? We run stock ballast. Thanks
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:22 AM.