Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #11  
Old 02-15-2013, 08:55 AM
Craig's Avatar
Craig Craig is offline
TT Enthusiast
 
Join Date: Jul 2005
Boat: Not a MC
Location: North Georgia
Posts: 377
Quote:
Originally Posted by ricford View Post
I don't think it's a matter of Indmar vs. PCM. The LT1 engine is built that way, and if I'm not mistaken it's the only one. The belt drives the alternator and the raw water pump, the circulating pump is on the cam. Hope you didn't overheat, because you had no raw water pump when you broke the belt.
It only drives the alternator on the LT1, no fear of overheating. However, without an alternator you can't really overheat anyway.
__________________
94 Prostar 190, LT-1, Powerslot [SOLD]

Reply With Quote
  #12  
Old 02-15-2013, 03:09 PM
ricford's Avatar
ricford ricford is offline
MC Fanatic
 
Join Date: Feb 2011
Boat: 1996 Prostar190
Location: Muskoka, Canada
Posts: 534
Quote:
Originally Posted by Craig View Post
It only drives the alternator on the LT1, no fear of overheating. However, without an alternator you can't really overheat anyway.
My mistake, you are correct. Had to go out and look at it to be sure.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:48 PM.