Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 01-28-2013, 05:32 PM
jmw jmw is offline
TT Enthusiast
 
Join Date: Apr 2012
Boat: 2009 214V
Location: Northeast (DC area)
Posts: 122
Trim Tab 214V / X-14V

Need some help on my trim tab. Has someone else has had their trim tab stop working and know a fix? Or is someone out there with a 2009 214V or X-14 with VDIG and a trim tab that can confirm which MiniMMDC and Lenco trim box is in their boat? It needs to be the same year but might not have to be a same model like an X-2 or something similar that only has the center trim tab because per Lenco multiple (surf) tabs is an entirely different system.

I purchased the boat last year and it was not working, dealer said it was the actuator, knocked a fair amount off the price and I thought I would fix it myself and a nightmare has ensued. I know it's not the actuator, because I can test it manually making it run using jumper wires. I have tested the Lenco brain box and it works correctly (Lenco has been extremely helpful). I have tested the switch and it works correctly. I have spoken with MC and here is where it got scary, the factory knew the boat when I described the problem.... It was apparently at a MC dealer that closed around Orlando, FL with same problem about 2 or 3 years ago and I don’t think it was ever fixed. The boat has a VDIG but MC says it didn’t leave the factory with a VDIG but it’s only had 2 owners (ski school and police chief) both seem trustworthy and they all state that’s the way it came. Lenco believed the brain box that was in the boat (Model: 30074-001 REV: B) wasn’t the correct box and even sent me what matched their records for a VDIG (Model: 30271-009) to test, but that didn’t fix it either. They both have 16 pin harnesses but are wired slightly different. That’s why I’m hoping someone can confirm what should be in the boat. Things I’ve tested:

Switch has common ground come in from brain box and when toggled grounds the wire for either up or down. If I wire the brain box directly to the switch it works but will not show up on the VDIG. I have followed the wires (trim up/down) from the switch and it appears they go to the MiniMMDC, they definitely enter that main wiring harness under that dash and without tearing into the harness you cannot follow them all the way.

Both lenco brain boxes bench test out and work correctly. I’m assuming that after the switch takes the common ground from the Lenco brain box and transfers it to either the up/down wire it runs through the MiniMMDC and then back to the Lenco brain box for some reason. Both brain boxes have a trim gauge output that’s why I’m not sure why/if the up/down wires go through the MiniMMDC. Attached is the wiring diagram from Lenco for the box that was in my boat but they indicate the up/down should just go to the switch which I have done and the tab works but won’t show up on VDIG. I don’t have the MC diagrams which would help because then I could test the wires as they go in and out of the MiniMMDC or wherever they are going.

I even borrowed a MiniMMDC same model # (M3 MiniMMDC 7022-0012-01) from a buddies boat (his doesnt have a trim tab) but that didnt fix it either.

I have tested all the hot and ground wires at the switch and Lenco brain box with a test light and volt meter and all check out.

I’m open to any suggestions because I’m stumped… I know it’s not the end of the world without a gauge because you usually watch the wake to adjust/dial it in but it drives me crazy that it doesn’t work correctly, MCOCD.

Last edited by jmw; 01-29-2013 at 06:41 PM. Reason: typo
Reply With Quote
  #2  
Old 01-29-2013, 06:45 PM
jmw jmw is offline
TT Enthusiast
 
Join Date: Apr 2012
Boat: 2009 214V
Location: Northeast (DC area)
Posts: 122
Just realized attachment missing. Anyone have any ideas???
Attached Images
File Type: pdf Model.30074.001.pdf (48.3 KB, 172 views)

Last edited by jmw; 01-29-2013 at 06:45 PM. Reason: typo
Reply With Quote
  #3  
Old 02-09-2013, 05:48 PM
jmw jmw is offline
TT Enthusiast
 
Join Date: Apr 2012
Boat: 2009 214V
Location: Northeast (DC area)
Posts: 122
Bump... Wow 102 views and no comments. I did some more checking today and confirmed the trim guage out wire from the Lenco box is working correctly. In case anybody ever has to check their gauge the wire should read 5 volts when all the way down and 0 volts when up. I'm about to give up on the VDIG and just install a regular guage.

Attached wiring diagram for Lenco brainbox with VDIG (Model: 30271-009); however MC has tied the trim up/down wires on pins 9 and 11 into the main wiring harness somehow and they dont go directly back from the switch to the Lenco brainbox. I wish I knew where they went because if I go directly from the switch back to the brainbox it works just doesnt show up on VDIG.

Suggestions????
Attached Images
File Type: pdf Model.30271-009.pdf (17.5 KB, 169 views)

Last edited by jmw; 02-11-2013 at 12:37 PM. Reason: Added Wiring Diagram
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:44 AM.