Go Back   TeamTalk > General MasterCraft Topics > General Discussion

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #15  
Old 01-31-2013, 10:27 AM
Memo's Avatar
Memo Memo is offline
TT Enthusiast
 
Join Date: Jul 2004
Boat: 2007 X1
Location: Michigan
Posts: 135
kalamalka - I am not certain when MC changed the ballast configuration on X1s from manifold to underwater thru-hull discharge. If your boat take-in and discharge water from the same underwater thru-hull and has 2 reversible ballast pumps fastened to the stern, here are some suggestions.
You can increase the ballast water flow by switching to 1 ID hose between the pump and the bag. Current factory hose is . After you have removed the tanks and the tank brackets, remove the two rear panels. It is good idea to check the pump impellers for condition and possible upgrade to green color impellers. While you have the rear panels removed, switch the ballast pump from right side up to upside down. You will see what I am talking about when you look at both stern ballast pumps at the same time. You need to switch only one of them. Mounting the pump upside down prevents water penetrating the electrical motor. This avoids future pump damage if the seal in-between the impeller and the motor fail. Current factory vent hoses that are attached to the hard tanks are not long enough for the bags. You need additional ID hose. Most definitely use the Flow-Rite Quick Release Connectors. You can purchase everything you need from Wakemakers.com.
Hope this helps. Good luck with your project.
__________________

2014 X30 on Order
2007 X1
- Midnight Black/Viper Red
- For SALE
1996 ProStar 190
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:14 AM.