Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #11  
Old 10-11-2012, 02:10 PM
KahunaCraft's Avatar
KahunaCraft KahunaCraft is online now
TT Enthusiast
 
Join Date: Oct 2012
Boat: 2012 X30, 6L
Location: Canada
Posts: 411
Options for solving the stereo control issues:

1. Connect an RF remote using a Y cable. The one listed in the link below floats, Or there are stationary marine grade remotes available, also uses Y connector. RF remote cost is in the $90 + Y $30 = $120. Price is based on eBay, if you don't shop around you'll pay 2x that.

http://www.clarion.com/ca/en/product...tes/index.html

2. Use this Bluetooth device.

http://www.clarion.com/ca/en/product...414876320.html

- my experience has been that streaming Bluetooth audio doesn't have as good (it's good but not great) as a wired connected device. That said, this might be the way I solve it for my boat. (Cost $60 + Y cable = $90)

3. In some cases I hear if you aim the remote at the blue part of the glove box, it works. (Free)

I also thought about using an IR extender, but it cost as much as the other options and isn't clean.
Reply With Quote
  #12  
Old 10-11-2012, 02:13 PM
KahunaCraft's Avatar
KahunaCraft KahunaCraft is online now
TT Enthusiast
 
Join Date: Oct 2012
Boat: 2012 X30, 6L
Location: Canada
Posts: 411
Actually, I'm going with the RF remote, that way when I'm tied up to other boats, my iPhone wont be subjected to unforeseen risks.
Reply With Quote
  #13  
Old 10-11-2012, 02:15 PM
FourFourty's Avatar
FourFourty FourFourty is offline
MC Fanatic
 
Join Date: Nov 2010
Boat: 2014 X30 with a lightly tickled LS7
Location: Northeast
Posts: 862
I have had every single problem listed in this thread.

Also, I have had launch control leaving the tabs down, while surfing and wakeboarding, and no ability to pull them up, even with the manual switches. As you all know, this ruins the wake behind the boat.

I cant fill the ballast correctly. I cant empty it correctly. Perfect pass doesnt hold speed, and it forgets settings all the time. screen goes blank. I lose radio controls. ballast guages are not even close to right. cant save rider settings. if i do get one saved, it doesnt activate half the time. the list goes on and on......

I absolutely loved my 2011 X25. My 2012 has disappointed me since day one. I am so frustrated with this boat, I don't know what I am going to do....
Reply With Quote
  #14  
Old 10-11-2012, 02:30 PM
rtw_travel's Avatar
rtw_travel rtw_travel is offline
TT Enthusiast
 
Join Date: Sep 2012
Boat: 2014 X-14V
Location: Alberta, Canada
Posts: 189
Ballast tank issues - pump won't run and gauge reads zero when the tank was actually about 2/3 full. I assume the ballast caused the wake to be huge - and skiing was not great. While the kids use it for wakeboarding, I wanted a ski boat so the X-14V was the correct compromise, if you trust the marketing literature. I have yet to have a happy tow behind it.

I haven't had other major difficulties - the gauges have all turned off and back on a few times while the boat was running, and the cruise control overshoots the set speed by ~2 mph before slowing back down. Perhaps that is normal for the cruise control?

There was only 10 hours on the boat before I put it into storage, and I'm nervous about the problems I might have next season already. Nervousness is not the feeling I should have when I spent this much on the new ski boat I've always dreamed about
__________________
2014 X-14V...pick up next summer
2012 X-14V (gone)

Last edited by rtw_travel; 10-11-2012 at 02:33 PM.
Reply With Quote
  #15  
Old 10-12-2012, 01:09 PM
bjames's Avatar
bjames bjames is offline
MC Devotee
 
Join Date: Jul 2011
Boat: 2009 X-Star LY6
Location: Alberta, Canada
Posts: 1,106
Due t the pain in the but having to switch screens constantly to adjust volumn, I decided that i am going to get a Clarion remote added just behind the throttle arm. I was considering mounting it like the 2013, but I really like the cubby hole - great place for my phone and sun glasses

IF MC decided to change out my BIG for a murphy system, then I would say with confidence, that my X25 will be the perfect boat.
__________________
Current: 2009 X-Star, Indmar 6L, 400hp, ZFT3 tower. c/w 1/9 scale R/C PWT X-Star

Owned:
2012 X25
2011 X25
2009 Moomba LSV
2009 Moomba Outback V
2008 Monterey FS180
Pelican 4 set paddle boat
plastic tug boat when I was 4
Reply With Quote
  #16  
Old 10-13-2012, 12:52 AM
Stefan's Avatar
Stefan Stefan is offline
TT Enthusiast
 
Join Date: Apr 2012
Boat: 2012 X-15...gone, 2014 X-46 Gen2+ ...incoming
Location: middle of Germany, center of Europe (the old world)
Posts: 386
My ZeroOff is still NOT working at all in RPM Mode. After the first run it only shows "Pull up" and never kicks in again. When disconnecting the GPS Sensor (full power off), fallback to PerfectPass occurs and RPM is working just fine.

When editing profile speeds huge numbers come up (only in metric mode not in english units) See here
Still can't believe nobody else is having this problem, since all canada is metric, because I tried two other 2012 boats and the both had the same problem.

Also what I've heard from a lot of owners is that if the people actually building the boat hear a boat is going to europe or overseas they don't care at all and just throw everything in there. I would bet my a** that my boat has never been.... taadaaa: "lake tested"


Quote:
Originally Posted by FourFourty View Post
Also, I have had launch control leaving the tabs down, while surfing and wakeboarding, and no ability to pull them up, even with the manual switches. As you all know, this ruins the wake behind the boat.
I've had this happen in the beginning too, turns out the cruise was always thinking we're not going fast enough for surfing with the original surf profile, so it was keeping all tabs down trying to get us up to speed ("on plane"). Actually I recall it putting the tabs down every 20 sec or so.
Solved it with setting up my own surf profiles.

Quote:
Originally Posted by bjames View Post
Due t the pain in the but having to switch screens constantly to adjust volumn, I decided that i am going to get a Clarion remote added just behind the throttle arm. I was considering mounting it like the 2013, but I really like the cubby hole - great place for my phone and sun glasses

IF MC decided to change out my BIG for a murphy system, then I would say with confidence, that my X25 will be the perfect boat.
Who will assure you that the Murphy system is working better, Mastercraft won't, tey'll stick to their legal stuff...
__________________
If You Find To Many Capitals You Can Keep Them...I'm German

Last edited by Stefan; 10-13-2012 at 01:09 AM.
Reply With Quote
  #17  
Old 10-13-2012, 07:34 AM
X25 ED's Avatar
X25 ED X25 ED is offline
TT Regular
 
Join Date: Oct 2009
Boat: mastercaft X2, 2009, MCX 350, Moomba LSV 2007 (sold), Maxum 1800 sx 2003 (sold)
Location: Europe, Netherlands
Posts: 81
Have a 2012 X25 with Power tower, with standard ballast, besides that the ballast is not filing completely or emptying completely and that sometimes switching between screens takes a while to load up the new screen everything is working as it should be.
Off course some times the power tower does not respond on the first push of the button, but that is nothing for me to worry about.

the only thing is that as far as my dealer can tell me there will not be a (factory under warranty)update for the power tower with new braces and hydraulics, by that I do not get it because as far as i know from this forum all 2012 power towers are updated by the dealer at mc cost.

Must say that the dealer is still working on it so i hope it will be done as it should.
Or is this because I life in Europe and get no service.......?
__________________
2012 X25 , 2009X2, 2007 Moomba, 2003Maxum
Reply With Quote
  #18  
Old 10-13-2012, 09:44 AM
FourFourty's Avatar
FourFourty FourFourty is offline
MC Fanatic
 
Join Date: Nov 2010
Boat: 2014 X30 with a lightly tickled LS7
Location: Northeast
Posts: 862
Quote:
Originally Posted by Stefan View Post
[b]Who will assure you that the Murphy system is working better, Mastercraft won't, tey'll stick to their legal stuff...
The reason why we are all wanting the murphy controls, is because murphy has proven to be excellent in Correct Craft boats. CC has been using murphy for several years now, and has had very little issues.

Talk to any newer Malibu and MasterCraft owner, and most of them can't say the same for the Medallion systems in our boats. The BIG and Malivue systems have been plagued with issues since day 1. Also, medallion is very slow at addressing problems.

MC made a very good move by switching.....
Reply With Quote
  #19  
Old 10-13-2012, 01:31 PM
Nick911's Avatar
Nick911 Nick911 is offline
MC Devotee
 
Join Date: Jul 2011
Boat: 2013 Mastercraft X25, 6.0 Ilmor, Pro Package, slammed and flaked!
Location: Canada
Posts: 1,069
Quote:
Originally Posted by FourFourty View Post
The reason why we are all wanting the murphy controls, is because murphy has proven to be excellent in Correct Craft boats. CC has been using murphy for several years now, and has had very little issues.

Talk to any newer Malibu and MasterCraft owner, and most of them can't say the same for the Medallion systems in our boats. The BIG and Malivue systems have been plagued with issues since day 1. Also, medallion is very slow at addressing problems.

MC made a very good move by switching.....
Big part of the reason I'm going to a 2013. No matter how well they try and support the 2012 medallion systems there will be continuous issues. I don't want to, 5 years from now, have a boat known for being from a lemon year.
Reply With Quote
  #20  
Old 10-13-2012, 06:34 PM
FourFourty's Avatar
FourFourty FourFourty is offline
MC Fanatic
 
Join Date: Nov 2010
Boat: 2014 X30 with a lightly tickled LS7
Location: Northeast
Posts: 862
Quote:
Originally Posted by Nick911 View Post
Big part of the reason I'm going to a 2013. No matter how well they try and support the 2012 medallion systems there will be continuous issues. I don't want to, 5 years from now, have a boat known for being from a lemon year.
I went and demo'd a 2013 X25 today..... I spent half the afternoon playing with ballast settings and cruise functions, just trying to get this Murphy system to mess up. Not a single issue presented itself. The user interface is very easy to operate, screen changes are much faster, and not a single glitch.

Even the ballast gauges were reading right, and filling, and emptying perfectly. The gauges would get up to 98% and you would start to hear the overflows. You hit empty, and at about 2-3% you would hear the pumps gargling air. Absolutely flawless. Cruise control was 200% more responsive, and 500% better at holding speed within .5 mph.

I honestly left there wondering how the hell the system could have advanced so much. A 2013 is in my future..... A special thanks to the folks at Castaway marina, for letting me demo that boat for as long as I needed to, to be convinced. WOW!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:47 PM.