Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 08-15-2012, 01:08 PM
badgerjfr's Avatar
badgerjfr badgerjfr is offline
TT Newbie
 
Join Date: Aug 2012
Boat: '84 mastercraft
Location: midwest
Posts: 12
Smile magor issues... HELP!

hello all,
im a new member and recently bought a 1984 ss knowing it needed a lot of work. challange accepted. after working on this thing for a couple months im at a loss. fisrt ill tell you what i know has been done to the boat then ill tell you my problem.

rebuilt 351 windsor installed
new impellor
all new hoses and belts
new distributor cap and rotor and plugs
new fuel filter
rebuilt 4160 holley marine carburator
and timed the engine once

every time i change/replace something, we take it to the water to test it and always have the same issues.

i can get the boat to idle awesome. it sounds good, revs and relaxes on command. as soon as i put it in gear it boggs so bad and doesn't want to go anywhere. pumping the throttle doesn't help, nothing seems to work. then if i try to put it back in neutral, the engine dies. then it seems a little harder to get it to start again. im at my whits end

couple things i havent tried yet
replace coil
replace fuel pump
checked breather or anti-siphon valve
had a boating friend tell me my firing order may be off and causing the problem

basically im looking for some guidance, ideas, correct firing order? whatever anyone can spare. i would really like to get this thing running before evrything freezes over for the winter. please help.

thanks for your time
-jeff
Reply With Quote
 

Tags
1984, engine boggs, idle, mastercraft

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:12 AM.