Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 08-13-2012, 01:22 AM
benvickers38 benvickers38 is offline
TT Newbie
 
Join Date: Jul 2012
Boat: 2007 X Star SS / Crusader 6.0 375HP
Location: Southeast
Posts: 4
Cool 'Check Engine' under power

Help! My stereo cuts off and the "CHK ENG" warning comes on when I'm at higher than idle power. What could that be?

2007 X-Star SS, 6.0L Crusader, WetSounds tower speakers w/ eBay-bought amp.

Any thoughts? Thanks.
Reply With Quote
  #2  
Old 08-13-2012, 09:12 AM
76S&S's Avatar
76S&S 76S&S is offline
MC Devotee
 
Join Date: Jun 2007
Boat: 2002 X Star
Location: At the lake or on the way to the lake!
Posts: 1,697
Sounds like a weak battery; give it a good charge and see if that is it.

I'm assuming that all other gauges check out ok.
__________________
Being on the water is best, but when I'm not on the water I'm on TT.

2002 X Star
Sold - 76 S&S
Reply With Quote
  #3  
Old 08-13-2012, 09:55 AM
JimN's Avatar
JimN JimN is offline
MC Master Poster
 
Join Date: Jul 2004
Posts: 11,349
Quote:
Originally Posted by benvickers38 View Post
Help! My stereo cuts off and the "CHK ENG" warning comes on when I'm at higher than idle power. What could that be?

2007 X-Star SS, 6.0L Crusader, WetSounds tower speakers w/ eBay-bought amp.

Any thoughts? Thanks.
Since it only happens when you go faster than idle, I would look at connections. Who installed the amp and how were the cables connected? Was it connected directly to the battery? If not, you need to do that. Proper termination of all cables is critical. It could be a bad connection at the battery, bad alternator, etc- as long as it cranks when you need it to, I don't suspect the battery.
Reply With Quote
  #4  
Old 08-13-2012, 09:58 AM
willyt's Avatar
willyt willyt is offline
MC Devotee
 
Join Date: May 2009
Boat: ER xstar
Location: high in the middle and round on both ends
Posts: 1,687
temperature?
oil pressure?
volts?
kicking you down into limp mode?

need more information
Reply With Quote
Reply

Tags
check engine, electrical, electrical problems, stereo

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:47 PM.