Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 07-07-2011, 12:56 PM
01MCX30 01MCX30 is offline
TT Newbie
 
Join Date: Jul 2011
Boat: 2001 MasterCraft X30
Location: Southeast
Posts: 7
2001 X30 Loss of Power - Safe Mode?

Just bought a 2001 MC X30 with the MX LTR 5.7L engine. We took it out yesterday and it ran great for about 3-4 hours. Then it seemed as if some sort of Guardian Mode kicked in and would not let me rev above about 1500-2000 RPMs. I had to idle about a half mile back to the ramp and put it back on the trailer.

I went through many of the posts on here about fuel pump, fuel filter, vapor lock, water in the fuel etc and then ran across a thread about using the paperclip and check engine light to check the codes. I ran the test and all I can get out of it is a Code 12. I posted a vid of my testing if anyone can confirm my understanding of the light flashes of the Check Engine Light.

You can checkout the vid at http://justtesting.biz/mc01/vid001.3gp

If anyone has other tips to help troubleshoot, I would love to hear them.

Thanks..................Terry
Reply With Quote
 

Tags
fuel problem, mefi test, x30

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:30 PM.