Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #21  
Old 05-24-2011, 02:01 PM
JJMorris3 JJMorris3 is offline
TT Regular
 
Join Date: Feb 2010
Boat: 1994 Mastercraft Prostar 205
Location: Austin
Posts: 87
Hi Baseman. Maybe I am crazy, but you have a question about the "button" on the throttle control. That is the kill switch that typically has a lanyard attached. If you can "see" the button, then perhaps it does not have the clip/lanyard attached, which it should to be able to operate the boat. THAT might explain why it doesn't run?
Reply With Quote
  #22  
Old 05-24-2011, 02:09 PM
baseman422's Avatar
baseman422 baseman422 is offline
TT Newbie
 
Join Date: May 2011
Boat: 1994 Mastercraft Prostar 190
Location: south
Posts: 17
I'm sure that's what it is. However I felt behind button today and there is nothing attached to it. And the boat ran last week. I think the previous owner bypassed the switch.
Reply With Quote
  #23  
Old 05-24-2011, 05:34 PM
etduc's Avatar
etduc etduc is offline
MC Fanatic
 
Join Date: Jul 2004
Boat: Mastercraft Prostar 205
Location: Looking for a windshield
Posts: 821
Quote:
Originally Posted by baseman422 View Post
I'm sure that's what it is. However I felt behind button today and there is nothing attached to it. And the boat ran last week. I think the previous owner bypassed the switch.
My Tristar kill switch, was by-pass.
__________________
Ayyyy!

1994 RED Mastercraft 205, Chevy 5.7 TBI.
Reply With Quote
  #24  
Old 05-24-2011, 05:39 PM
etduc's Avatar
etduc etduc is offline
MC Fanatic
 
Join Date: Jul 2004
Boat: Mastercraft Prostar 205
Location: Looking for a windshield
Posts: 821
Quote:
Originally Posted by baseman422 View Post
ok, new question now. I really need help with this one. Two weeks ago at the lake the starter sounded like it was getting bogged down and didnt want to start. So this weekend we took the starter out and replaced it. now the boat will turn over great but it will not start. We have compression and a spark the pistons are moving and i can see the injectors pumping in fuel. also replaced the spark plugs, dist cap and rotor. If anyone has a sugestion I would greatly appreciate it. Thanks
Check your firing order. again.
__________________
Ayyyy!

1994 RED Mastercraft 205, Chevy 5.7 TBI.
Reply With Quote
  #25  
Old 05-24-2011, 05:54 PM
BigJon BigJon is offline
TT Regular
 
Join Date: Apr 2009
Boat: 94 Mastercraft
Location: Central California
Posts: 37
I have a 94', when I get home I will try and take a pic and post it.
Reply With Quote
Reply

Tags
1994, prostar, throttle

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:56 AM.