Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 05-23-2011, 09:52 PM
pboyce
Guest
 
Posts: n/a
Ballast in 04 X7

Hi all

I recently bought an '04 X7 and have some questions about the ballast. When i bought the boat it didn't come with a manual or anything detailing use of the ballast.

I have a switch on the console to fill/empty the sack. When I flick it to fill, it sounds like it is sucking a lot of air into the pump and the fat sack fills slowly. If i stick my finger into the discharge hole on the side of the boat (or use one of the plugs that came in the glove box that seem to fit into this hole), the pump seems to work a bit harder and actually pumps water and the bag fills a lot faster.

If I dont plug the discharge hole on the starboard side of the boat, it takes a very long time to fill the bag. Is it normal to have to plug the dischage outlet to fill the bag? Or is there something wrong with the pump. Any ideas? Im reading on various posts about replacing the impellar?

Does anyone here have any other tips on using the ballast? Are the two pipes on the port side of the boat strictly for venting purposes?

Also - how long should the bag take to fill and empty?

Thanks for all your advice! This is a great forum you have hear.
Reply With Quote
 

Tags
ballast, fat sack, rear ballast

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:11 PM.