Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 07-14-2010, 12:58 PM
cwtxmc
Guest
 
Posts: n/a
JL Audio Problems

I have a 2006 X-Star with the standard 6 interior speakers, sub, and 2 tower speakers. For some reason I have been losing speakers left and right. They started going out on the port side, and now I'm left with just one of the tower speakers, sub, and speaker right behind the driver. They have been going out one by one...very strange. Has anyone had this problem or know any tricks to fix it? I'm pretty knowledgable with sound systems, but this has me stumped.

Thank you!
Reply With Quote
  #2  
Old 07-14-2010, 02:04 PM
vision's Avatar
vision vision is offline
MC Devotee
 
Join Date: Jun 2006
Boat: 2008 X Star, 2005 X2
Location: Cary NC, Lake Gaston
Posts: 1,071
If you switch speaker wire connections at the amps, do the working speakers stay the same or correspond to speaker ports on your amps?
__________________
2008 X star, 2005 X2
Reply With Quote
  #3  
Old 07-14-2010, 09:22 PM
cwtxmc
Guest
 
Posts: n/a
I just messed around with it. I moved connections around and everything. Now I just have one tower speaker, no sub, and one interior speaker...one that wasn't working before. It seems as if the problems are getting worse.
Reply With Quote
  #4  
Old 04-22-2011, 06:12 PM
davidstan's Avatar
davidstan davidstan is offline
MC Fanatic
 
Join Date: Jul 2004
Boat: 2008 X2
Location: AL/GA
Posts: 579
Did the OP get an answer to his losing speaker issue. I have the same proble
My 2 bow speakers and one behind the driver. I am not good with sound systems and no one within 60 miles has a audio shop to take to.
__________________
David
2008 X2 MCX
1999 Maristar 210 (sold)
1996 Bayliner 2050
Reply With Quote
  #5  
Old 05-07-2011, 10:42 AM
BIGandUGLY BIGandUGLY is offline
TT Newbie
 
Join Date: May 2011
Boat: 1985 Mastercraft Stars and Stripes
Location: Texas
Posts: 3
It can be tracked down and isolated by doing what Vision suggested. If only one channel (speaker port) is working then its an amp issue. If none of the other speakers will work on that same channel that plays then its a speaker issue.
Reply With Quote
Reply

Tags
audio, problems, speakers

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:06 PM.