Go Back   TeamTalk > General MasterCraft Topics > General Discussion

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 04-21-2011, 09:51 PM
ShawnB's Avatar
ShawnB ShawnB is offline
TT Enthusiast
 
Join Date: Jul 2004
Boat: N/A
Location: Northeast
Posts: 441
It's Here! X-25 Delivered today....

First off, we couldn't be happier with how the boat turned out. Thank you to Jay, Bill, and Mikey at New England Freshwater Marine! Took it out for a maiden voyage in the 50 degrees air with 20+ mph winds. Can't wait to get out on that wake this weekend....

Now a couple issues I noticed...
- Plug and play ballast... It turns out that the front bag for the plug and play is intended to go in the walkway. Woah, that was totally unexpected. Can anyone else with an X25 and plug-and-play shed a little light on this? We were thinking that we may need to have some custom bags made for under the front seats but there's not a lot of room there. Also I broke off one of the clips that attach to the bags. *$#@$@

- Center flip-down cupholders/step. It's in the brochure. It's in the Zane video. It was even in the X25s at the factory and at the boat show. It's not in this boat. Please tell me this is a joke, i was actually looking forward to this feature!
Attached Images
     
Reply With Quote
 

Tags
x25

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:17 AM.