Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 04-10-2011, 07:07 PM
mike9826
Guest
 
Posts: n/a
08 X45 SS, LY6, Coolant coming out of exhaust

I just had a new LY6 long block installed by our local Nautique shop, and I got the boat in the water for the first time and noticed the temp gauge starting to rise so I shut down the engine and ran to get some more Dex-Cool. I just figured they didn't purge the system well. I ended up adding another gallon of coolant while trying to burp the system and this thing just kept taking what ever I could put in it.

I pulled the boat out of the water and hooked up the boat to the flush kit. I noticed coolant came out of the port side exhaust. I pulled the hose loose that comes off of the heat exchanger and goes to the bottom side of the exhaust flange that goes to the exhaust hose. There was also red water in there. Has any one else had this happen? I think I have it diagnosed down to a bad heat exchanger, but it is hard to 100% sure. The hoses look like they were all installed properly, but if anyone has access to a Indmar service manual I would greatly appreciate a diagram that would show the proper routing just in case.

Thank you!
Reply With Quote
Reply

Tags
coolant, exhaust, heat exchanger, ly6, x45 ss

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:09 PM.