Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 03-07-2011, 11:18 AM
jpcarter jpcarter is offline
TT Regular
 
Join Date: Apr 2010
Boat: 2007 Mastercraft X2 SS MCX
Location: Southeast
Posts: 36
Question Where's the diagnostic port on a '07 X2 SS MCX

Where is the diagnostic port located on an '07 X2 SS with an MCX? I borrowed a Diacom code reader setup & want to scan & diagnose the codes. Just don't want to hunt & seek for 30 minutes trying to find the jack.

The "Check Engine" indicator came on last summer with it's accompanying audio warning on the MCX equipped 2007 X2 SS. Was able to turn off the indicator and alarm by hitting the display selector, but it came on again and again - and only under load.

Oil pressure was normal (40-60) as was the engine temp (~160). No unusual sounds. No power loss. Idle and acceleration all normal.

Tried unplugging the battery overnight. No effect.
Tried cycling the engine from cold to running temps multiple times. No effect.
Reply With Quote
  #2  
Old 03-07-2011, 02:16 PM
SkiDog's Avatar
SkiDog SkiDog is offline
MC Addict
 
Join Date: Jun 2005
Boat: 92 Prostar
Location: South of North
Posts: 7,246
Quote:
Originally Posted by jpcarter View Post
Where is the diagnostic port located on an '07 X2 SS with an MCX? I borrowed a Diacom code reader setup & want to scan & diagnose the codes. Just don't want to hunt & seek for 30 minutes trying to find the jack.

The "Check Engine" indicator came on last summer with it's accompanying audio warning on the MCX equipped 2007 X2 SS. Was able to turn off the indicator and alarm by hitting the display selector, but it came on again and again - and only under load.

Oil pressure was normal (40-60) as was the engine temp (~160). No unusual sounds. No power loss. Idle and acceleration all normal.

Tried unplugging the battery overnight. No effect.
Tried cycling the engine from cold to running temps multiple times. No effect.
SOMEBODY help this man! This is my previous boat! JimN, anybody?????????
Reply With Quote
  #3  
Old 03-07-2011, 02:24 PM
jpcarter jpcarter is offline
TT Regular
 
Join Date: Apr 2010
Boat: 2007 Mastercraft X2 SS MCX
Location: Southeast
Posts: 36
thanks ski dog!
Reply With Quote
  #4  
Old 03-07-2011, 02:28 PM
Sodar's Avatar
Sodar Sodar is offline
MC Master Poster
 
Join Date: Nov 2004
Boat: '07 ProStar 197 w/ MCX
Location: Seal Beach, CA
Posts: 11,071
I believe all the ports are on the rear of the engine. I do not know exactly, but when the dealer hooked mine up to the computer, they went straight to the driveshaft side of the engine where all the electrical connections and ECU are.
__________________
-Cameron
2007 ProStar 197
1996 ProStar 190
Reply With Quote
  #5  
Old 03-07-2011, 03:11 PM
jpcarter jpcarter is offline
TT Regular
 
Join Date: Apr 2010
Boat: 2007 Mastercraft X2 SS MCX
Location: Southeast
Posts: 36
Also...does anyone have the basics of pulling the codes using the tool? As in...do I run the tool with the ignition off? Or, ignit on, w/engine off? W/engine running?

Tips appreciated.
Reply With Quote
  #6  
Old 03-07-2011, 03:28 PM
Sodar's Avatar
Sodar Sodar is offline
MC Master Poster
 
Join Date: Nov 2004
Boat: '07 ProStar 197 w/ MCX
Location: Seal Beach, CA
Posts: 11,071
Quote:
Originally Posted by jpcarter View Post
Also...does anyone have the basics of pulling the codes using the tool? As in...do I run the tool with the ignition off? Or, ignit on, w/engine off? W/engine running?

Tips appreciated.
Ignition On, Engine Off.
__________________
-Cameron
2007 ProStar 197
1996 ProStar 190
Reply With Quote
  #7  
Old 03-09-2011, 04:01 PM
jpcarter jpcarter is offline
TT Regular
 
Join Date: Apr 2010
Boat: 2007 Mastercraft X2 SS MCX
Location: Southeast
Posts: 36
Just found out my the diagnostic code reader that I had access to isn't setup to connect to Indmar.

Where's the best place online to get Indmar diagnostic tools and what is your recommendation for a pro-sumer model?
Reply With Quote
  #8  
Old 03-09-2011, 04:32 PM
Sodar's Avatar
Sodar Sodar is offline
MC Master Poster
 
Join Date: Nov 2004
Boat: '07 ProStar 197 w/ MCX
Location: Seal Beach, CA
Posts: 11,071
When I was really researching, I was given these two addresses....

http://mefiburn.com/

and

http://www.rinda.com/

My thread: http://mastercraft.com/teamtalk/show...highlight=MEFI
__________________
-Cameron
2007 ProStar 197
1996 ProStar 190
Reply With Quote
  #9  
Old 03-09-2011, 05:43 PM
jpcarter jpcarter is offline
TT Regular
 
Join Date: Apr 2010
Boat: 2007 Mastercraft X2 SS MCX
Location: Southeast
Posts: 36
Thanks Sodar. Will look at getting one of those. For now....Found a local Indmar mechanic. Going to have him use his test rig to pull the log Friday morning for ~$100.
Reply With Quote
  #10  
Old 06-09-2013, 11:46 AM
BobbyG BobbyG is offline
TT Newbie
 
Join Date: Jun 2013
Boat: 2007 MasterCraft X2-SS
Location: Southeast
Posts: 1
Hi JP

I have the same year model boat. Last summer I started experiencing the same issues. However, once or twice I would lose power and see my oil pressure drop quickly then pop back up to normal.
What did you find was the issue with yours?

Thanks
Reply With Quote
Reply

Tags
check engine, check_engine, code, diagnostic, mcx

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:55 PM.