Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 07-22-2010, 12:33 PM
jakeand94
Guest
 
Posts: n/a
Exclamation Blown Amp?

Hello Team Talk, I got a problem. I have a tower with 4 speakers, 4 speakers in the boat, and a stereo. The speakers in the boat work perfectly, but the tower speakers don't make any noise. I originally thought that I needed another amp to support the tower speakers. But, I looked and my amp doesn't receive any power. After tracing the power wire to the batteries, switched from negative to positive, still no power. I switched the fuses from the battery to the amp, no power. Today I am going to try to switch the amp fuses. Do I just need a new amp or something else?
Reply With Quote
  #2  
Old 07-22-2010, 03:06 PM
Kyle's Avatar
Kyle Kyle is offline
MC Maniac
 
Join Date: Jan 2007
Boat: 93 Prostar 190
Location: Fort Worth, TEXAS
Posts: 3,182
Make sure that the amp has pos and neg going to their correct connections. Make sure that you have 12v. Then make sure that the blue REM or Remote wire is connected. If you need to jump a wire from one amp rem to the other.
__________________
Rollin' Gangsta Style

Quote:
Originally Posted by Thrall View Post
"Heavy" beer is for wine drinkers that are too embarrassed to drink wine in front of their buddies. "Light" beer is a drinkin' man's beer!
Quote:
Originally Posted by thatsmrmastercraft View Post
If you want bling like the big dawgs, ya gotta lift your leg a little higher.....
Reply With Quote
Reply

Tags
amp, blown, issues

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:08 PM.