Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 06-09-2010, 02:02 PM
cdevro's Avatar
cdevro cdevro is offline
TT Enthusiast
 
Join Date: Apr 2008
Boat: MasterCraft X2 350
Location: Southeast
Posts: 100
Blown motor 08X2 400 hours.

Last month my engine started knocking after a day on the water, no alarms, no warning signs. The 400 hour 350 MCX engine has been maintained at regular intervals.Orginally it was thought to be under warranty but in the end I paid the bill. The cheap plastic intake screen on the botom of the boat was broke from an unkown object. Weeds were allowed to pass right into the cooling system eventually clogging the transmission cooler and then overheating the motor. THe argument that I have is why wouldn't the temp sender be able to pick up on the high temp? (it was tested and found to be in working condition and no codes showed up on diagnostics of the engine) THe plastic screen has been replaced with the brass intake that is on most of MasterCraft boats. Why they went plastic is beyond me.
SO lessons learned:
1. clean and inspect transmission cooler screen periodically
2. fully inspect under boat each time you pull it out of the water. (I do this everytime ,but the trailer bunks block the view of the intake unless you really get under it.
3. If you have the plastic intake screen replace it !


Check out the pics!
Attached Images
   
Reply With Quote
 

Tags
08 x2, blown motor, engine, overheat, weeds

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:08 AM.