Go Back   TeamTalk > General MasterCraft Topics > General Discussion

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 06-24-2009, 05:20 PM
scubajeff's Avatar
scubajeff scubajeff is offline
TT Newbie
 
Join Date: Jul 2008
Boat: 1990 Maristar 240, 454, dimension tower, polk/clarion sound
Location: SE
Posts: 17
90 240sc tranny shifting late in fwd only after visit to mech

greetings all wetheads, hope your summer is progressing along nicely.

I had an issue with a seized steering line, mech freed it up said he had to heat ti to loosen it up. which worries me- but he said it didnt need anything new. ok fine. but now it is shifting late, he is on vacation and im wanting to put it in the water again this weekend. fluid level looks good, looks fresh actually.
reverse works as normal. engages at the same point as before.
but fwd doesnt engage until very very late, engine is fairly well wound up before it will catch. seems to get better when ive worked it a good bit.- i know that sounds odd.

no bad smells, no other issues of note.

any ideas or thought appreciated. and if you know of a thread that covers this pls let me know, i drilled through several posts, most were on leaking seals.

thanks
__________________
90 maristar 240, 454, dimension tower, clarion-polk sound.
Reply With Quote
 

Tags
late shifting, slipping, transmission

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:22 PM.