Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 06-22-2009, 11:30 AM
Scottiepipn33
Guest
 
Posts: n/a
Engine Help please

I have a 2001 X-10. When the boat is in neutral, the engine runs and rev's up fine. But once I put it in gear, and hit the throttle, it backfires and will only go about 5mph at full throttle. Does anyone have any ideas of what it might be? I have had it in the shop and still am having the same problem. Any help or suggestions would be greatly appreciated!
Thanks!
Reply With Quote
  #2  
Old 06-22-2009, 06:04 PM
Scottiepipn33
Guest
 
Posts: n/a
It also backfires... But there is a new fuel filter, so I am stumped to what could be wrong, maybe something electrical?
Reply With Quote
  #3  
Old 06-22-2009, 06:10 PM
bigmac bigmac is offline
MC Platinum
 
Join Date: Jun 2005
Boat: 2004 Maristar 230 VRS
Location: Central Minnesota
Posts: 8,126
Timing may be off. Another possibility is plug wires out of normal firing order.
__________________
'04 MariStar 230VRS/MCX
Reply With Quote
  #4  
Old 06-22-2009, 06:45 PM
corey's Avatar
corey corey is offline
MC Devotee
 
Join Date: Oct 2005
Boat: between boats
Location: Nordeast Minneapolis
Posts: 1,356
Check the plugs and wires, my guess is one (or more) of them is bad.
Reply With Quote
  #5  
Old 06-23-2009, 02:20 PM
MCVOLS's Avatar
MCVOLS MCVOLS is offline
TT Enthusiast
 
Join Date: Mar 2009
Boat: '08 X14 MCX Slot
Location: Southeast
Posts: 236
Had a similar problem after a tune up. Not as bad as yours sounds, but would backfire under a load. Idle was fine. Re-checked the 'new' plugs, and one was cracked. It got worse as we continued to run, I guess the crack got worse as it heated up. As mentioned, plugs/wires/timing sound like a logical starting spot.
__________________
2008 X-14 MCX
1993 Prostar 205
1982 S&S
Reply With Quote
Reply

Tags
2001, mastercraft, x-10

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 02:17 PM.