Go Back   TeamTalk > General MasterCraft Topics > General Discussion

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 05-25-2009, 10:09 PM
CODY_YARBER07's Avatar
CODY_YARBER07 CODY_YARBER07 is offline
TT Regular
 
Join Date: Aug 2005
Boat: 1983 Mastercraft 19 Skiier Stars and Stripes
Location: East
Posts: 88
Send a message via MSN to CODY_YARBER07
Engine getting hot!!!

I just took my boat out for its first voyage of the summer and as I am idling out of the "no wake zone" I notice that the temperature gauge is almost in the red. I immediately turned the engine off and waited for it to cool down. After that I started it back up and drove to the houseboat with no problems. As soon as I get back to idle speed it heats up again. Not in the red but almost. Basically.. It only gets hot if you are idling. If you are going down the lake at speed then it runs a lot cooler than it usually does granted the water is still pretty cold. I have a feeling that it is either a thermostat or impeller but am not really sure and haven't checked either. If anybody has any clue what's going on here I'd love to know. My boat is an 83 S&S with the 351W. Thanks peoples!
__________________
1983 Mastercraft Stars and Stripes
351 With Powerslot
Reply With Quote
 

Tags
engine, impeller, overheat, temperature, wakeboarding

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:26 AM.