Go Back   TeamTalk > General MasterCraft Topics > General Discussion

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 06-08-2008, 05:58 PM
rdowdell
Guest
 
Posts: n/a
Thumbs down Port riser getting too hot to touch.

i have read only one other thread that discussed this issue but there was no answer to the problem given... i hope someone can help.

i have a 94 mastercraft maristar 225 vrs with the indmar 5.7l gm small block. last season we had a day from h*ll thats seen the boat on the trailer since.

it all started with a blown impeller which caused the engine to overheat. the warning buzzer came on and i pulled off throttle. i've had this problem before and imediatly recognized what to do. the only thing i didnt count on was the fact that we had lost the port exhaust flapper somewhere along the way that day (i realized this after we pulled it back onto the trailer). when the boat came to a stop the backwash swirled around the transom and an audile crack/knock sound came from the engine compartment, along with a decent steam plum from the rear of the boat. this was something that i did not recognized so we shot off a couple of flares and were towed back in.

after fixing the impeller i checked the oil and it was full of water, and so were the cylinders. i assumed this was a result of the backwash and no flapper. i changed the oil/sparkplugs/ sprkplug wires and distributor cap. i took her back out and she started up just fine. oil pressure is great, my engine temp holds a steady 160'ish, and there is plenty of go when i punch it. my only problem is that the port exhaust riser begins to heat up immediatly after starting the engine as compared with the starboard riser. under idle/marina speed this temperature difference is barely noticle as both risers stay cool enough to touch and i can run the boat like that for hours if i wanted to. but once you push it past 2000 rpm the "crown" of the riser begins to heat up quite considerably after only a minute or so. this heat then transfers through the rest of the riser and begins to heat up the exhaust manifold as well. after 2 minutes or so you begin to smell that "hot engine" smell and you can only keep your hand on the riser for a couple of seconds while the starboard side remains so cool you'd be able to keep it there indefinately.

i have checked all of the hoses for blockage and have also ruled out the thermostat as the flow coming from the housing to the exhaust manifolds is the same on both sides. i replaced the exhaust manifold after removing about 2 tablespoons of rust and debris and still the exact same problem.

should i change the riser next or could my problem still be a blockage somewhere. my engine temp holds steady though... a blockage would cause the whole thing to overheat no? when i removed the exhaust manifold i inspected the riser and it appeared in decent shape and there was no blockage. i have also recently inspected the silencers and they too appear to be ok.

if anyone could please help... this seems to bewilder every boat mechanic i have talked to in this city (calgary, ab, canada). our season is short enough and the fact that this boat still isnt running drives me crazy...i have three weeks before our first planed trip, hopefully i can bring a working boat.

thanks in advance, ryan
Reply With Quote
 

Tags
everheating, exhaust, riser, uneven

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:07 AM.