Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 08-21-2014, 03:41 PM
tommurtha tommurtha is offline
TT Regular
 
Join Date: Jul 2014
Boat: Prostar 197 2003
Location: Northeast
Posts: 42
where does the perfect pass plug & play harness hide

I have a 2003 prostar 197, trying to install a older perfect pass module and step motor etc.that came with the boat uninstalled. I had no harnesses. Perfect pass has been helpful but so far no joy. They made me a harness as I was missing it. They said it is under the dash, it isn't as far as I can see, They mentioned a panel that unscrews (maybe) that I don't recall seeing. (The boat is 90 minutes away). The mat area by my feet unscrews, there? It is a 6 hole connector that I can't seem to find. Perfect Pass said every Mastercraft from 2002 has the plug & play harness. Please help me find it. I'm no good at wiring from scratch
Reply With Quote
  #2  
Old 08-21-2014, 04:04 PM
franciscolalas franciscolalas is online now
TT Regular
 
Join Date: Mar 2006
Boat: Prostar 209 2004
Location: portugal
Posts: 66
Hope it helps!

Look for the connector behind the foot panel.
Attached Images
File Type: pdf ppmc.pdf (959.8 KB, 58 views)
Reply With Quote
  #3  
Old 08-21-2014, 04:29 PM
Jayhawk's Avatar
Jayhawk Jayhawk is offline
TT Enthusiast
 
Join Date: Oct 2013
Boat: 2001 X-Star
Location: Kansas
Posts: 349
http://www.mastercraft.com/teamtalk/...ad.php?t=58473
Reply With Quote
  #4  
Old 08-21-2014, 05:29 PM
tommurtha tommurtha is offline
TT Regular
 
Join Date: Jul 2014
Boat: Prostar 197 2003
Location: Northeast
Posts: 42
nice link that may come in handy if I can ever find the connector in the boat
Reply With Quote
  #5  
Old 08-24-2014, 09:59 AM
tommurtha tommurtha is offline
TT Regular
 
Join Date: Jul 2014
Boat: Prostar 197 2003
Location: Northeast
Posts: 42
found my connector. Unfortunately it looks like mastercraft took a crimping tool to it. It is so distorted that it won't come close to plugging in. So what should have been a plug & play is now cut and install a new plug. Nothing ever seems to go easy
Reply With Quote
  #6  
Old 08-24-2014, 10:28 AM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,340
Quote:
Originally Posted by tommurtha View Post
found my connector. Unfortunately it looks like mastercraft took a crimping tool to it. It is so distorted that it won't come close to plugging in. So what should have been a plug & play is now cut and install a new plug. Nothing ever seems to go easy
Don't cut the wires, get the correct tool and de-pin the plug. Then just replace the plug.
__________________
Tim
Gone, surfing.
Reply With Quote
  #7  
Old 08-24-2014, 10:36 AM
tommurtha tommurtha is offline
TT Regular
 
Join Date: Jul 2014
Boat: Prostar 197 2003
Location: Northeast
Posts: 42
I could not figure out how to de-pin the plug Any idea how and where to get the tool. I was planning on heading to Radio shack to see what they might have. The mating connector from perfect pass does not look like is comes apart. The wire terminals snap in I can push the wire & terminal out and pull s back in with a snapping sound.
Reply With Quote
  #8  
Old 08-24-2014, 10:42 AM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,340
I'd have to go look at my plug, but I bet either a delphi de-pinning tool or weather-pak tool would work.

https://www.google.com/search?q=delp...=1920&bih=1080

I have both and would think the weather-pak tool would work if the pins are the round type.

__________________
Tim
Gone, surfing.
Reply With Quote
  #9  
Old 08-24-2014, 11:12 AM
tommurtha tommurtha is offline
TT Regular
 
Join Date: Jul 2014
Boat: Prostar 197 2003
Location: Northeast
Posts: 42
On the connector perfect pass sent, It sure looks like the wires are inserted then crimped to the terminals then pulled back into the connector, snapping in. I assumed the boat connector is the same.
Reply With Quote
  #10  
Old 08-24-2014, 11:20 AM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,340
I'm not sure, I'd have to go look at mine. It's been a while.
__________________
Tim
Gone, surfing.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:57 AM.