Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

Thread Tools Display Modes
Old 07-11-2014, 06:40 PM
TallSkinnyGuy TallSkinnyGuy is online now
TT Enthusiast
Join Date: Aug 2013
Boat: 1997 Prostar 190
Location: Nor Cal
Posts: 261
Corrosion -- something to replace? '97 PS190 350 tbi

While looking around at the back of the engine due to an unrelated issue I shined my light down in the area on the starboard half of the back of the engine and noticed that the terminals for the black wires with the yellow stripe in the middle of the picture below are very corroded and there is a defined "pool" of rust-colored bumpiness on the wall where the wires are connected.

There are a ton of electrical connections back there and I didn't want to start messing with stuff until having a better understanding of what this is. I'm guessing corrosion is bad and I should replace these wires and clean up the area, but is there anything I need to be careful of when doing this? Any particular process that must be followed?
Attached Images
Reply With Quote
Old 07-11-2014, 07:16 PM
André's Avatar
André André is offline
MC Maniac
Join Date: Jul 2004
Boat: Prostar 190 1994
Location: Near Sherbrooke,Québec,Canada
Posts: 4,615
To be on the safe side,disconnect battery then remove, clean and thighten.
Not seing the corrosion very well...
Keep skiing!!!
Reply With Quote
Old 07-11-2014, 07:17 PM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 13,653
Send a message via Skype™ to mikeg205
Disconnect battery take apart clean... Reassemble attach battery ... I did this on mine

Sent from my iPhone using Tapatalk
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
Old 07-11-2014, 07:29 PM
Bouyhead's Avatar
Bouyhead Bouyhead is offline
MC Devotee
Join Date: Feb 2009
Boat: 1996 PS 190
Location: NYC
Posts: 1,223
When you back out those cad plated bolts You will find all the engine harness grounds. There should be at least three or four make sure they are clean.
1996 ProStar 190
PCM ZR6 W/ Zero Off
Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -4. The time now is 08:06 PM.