Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

Reply
 
Thread Tools Display Modes
  #4771  
Old 05-15-2014, 09:20 AM
ProStar200's Avatar
ProStar200 ProStar200 is offline
TT Enthusiast
 
Join Date: Apr 2009
Boat: 2010 MasterCraft X25
Location: Ottawa, Ontario, Canada
Posts: 281
Installed new Shield Decal from Josh at Sirlin.
Attached Images
 
Reply With Quote
  #4772  
Old 05-15-2014, 07:27 PM
FoggyNogginz's Avatar
FoggyNogginz FoggyNogginz is offline
MC Fanatic
 
Join Date: Aug 2006
Boat: 1998 PS205, then a 2002 X9, and now a 2012 X14V
Location: Center Hill Lake & Old Hickory
Posts: 709
New ACME 2059. Less pitch / More diameter. Hopefully trying it out this weekend!
Attached Images
 
__________________
----------------------------------

"KC"

Cmon...lemme just push one button...
- Red X14V on Center Hill & Old Hickory lakes in TN -
Reply With Quote
  #4773  
Old 05-16-2014, 09:45 PM
strad's Avatar
strad strad is offline
TT Enthusiast
 
Join Date: May 2010
Boat: 1984 Stars and Stripes Powerslot
Location: Las Vegas, NV
Posts: 453
Installed a correct arco marine starter in my 84. I bought it with an incorrect auto starter in it. I feel safer now. Only took about a half hour.
__________________
1984 Stars and Stripes Powerslot
White with blue stripes. purchased 9/2012
Reply With Quote
  #4774  
Old 05-16-2014, 10:59 PM
monsterwake's Avatar
monsterwake monsterwake is offline
TT Enthusiast
 
Join Date: Aug 2012
Boat: 2006 Mastercraft X1
Location: East Texas
Posts: 189
I had to paint these vent covers. White just didn't go with anything.
Attached Images
  
Reply With Quote
  #4775  
Old 05-17-2014, 12:09 AM
clrussell's Avatar
clrussell clrussell is offline
MC Devotee
 
Join Date: Jul 2012
Boat: 1990 mastercraft p190
Location: midwest
Posts: 2,062
Last few days I've installed a new aux plug in, old was in the glovebox and new is next to cig plug in under throttle. Installed another battery, I now have 2 on bank 2 and 1 on bank 1 of the Perko. Installed my new to me jl m400 for the tower speakers. Cleaned up some amp wiring and tracked down which wires I need for led tower rings.

Hopefully Sunday morning I can install my wake makers kit to plumb in the 750s in the rear before we go hit the water.
__________________
1990 prostar 190, 351, powerslot 1.5:1, tinted windows
Reply With Quote
  #4776  
Old 05-17-2014, 12:11 AM
thatsmrmastercraft's Avatar
thatsmrmastercraft thatsmrmastercraft is offline
MC Master Poster
 
Join Date: Sep 2008
Boat: 1977 Stars & Stripes
Location: St. Paul, MN
Posts: 15,164
Quote:
Originally Posted by strad View Post
Installed a correct arco marine starter in my 84. I bought it with an incorrect auto starter in it. I feel safer now. Only took about a half hour.
You will love that starter.
__________________
Peter

SPECIAL PRICE
ST205/75R15 KENDA LOADSTAR ON 15X5 WHITE SPOKE WHEEL, BALANCED & DELIVERED - $125 EACH


Tandem Axle Packages Starting at $569 - 4 Aluminum wheels, 4 ST205/75R14 tires, mount & balance.
Single Axle Package Starting at $319 - 2 Aluminum wheels, 2 ST205/75R14 tires, mount & balance.

CARBURETOR REBUILDING - $125 + PARTS
LED lights, Hubs, Spare Tire Carriers, Chrome & Powder Coated Lug Nuts

PM or email me tiresplease@gmail.com
*** FREE DELIVERY ON ALL ORDERS ***
Reply With Quote
  #4777  
Old 05-17-2014, 01:44 PM
strad's Avatar
strad strad is offline
TT Enthusiast
 
Join Date: May 2010
Boat: 1984 Stars and Stripes Powerslot
Location: Las Vegas, NV
Posts: 453
Quote:
Originally Posted by thatsmrmastercraft View Post
You will love that starter.

Well I was real happy when, after rewiring according to the instructions and installing, I connected the battery and a: no sparks or fire and b, it fired right up with no funny noises!
__________________
1984 Stars and Stripes Powerslot
White with blue stripes. purchased 9/2012
Reply With Quote
  #4778  
Old 05-18-2014, 12:38 AM
MI_Corey's Avatar
MI_Corey MI_Corey is offline
MC Fanatic
 
Join Date: May 2013
Boat: 2008 X1
Location: Michigan
Posts: 583
Installed my boat buddy transom straps. Really happy with them. Now I'm going to get one for the bow too.
Reply With Quote
  #4779  
Old 05-18-2014, 12:01 PM
clrussell's Avatar
clrussell clrussell is offline
MC Devotee
 
Join Date: Jul 2012
Boat: 1990 mastercraft p190
Location: midwest
Posts: 2,062
Installed my wakemakers ballast fittings, plumbed 750s in the rear lockers. Hopefully get to try it out today!
__________________
1990 prostar 190, 351, powerslot 1.5:1, tinted windows
Reply With Quote
  #4780  
Old 05-21-2014, 07:49 AM
JamesL JamesL is offline
TT Enthusiast
 
Join Date: Mar 2014
Boat: mastercraft X45 2008 LY6
Location: ohio
Posts: 116
took some old light housings off a harley and put some bright bulbs in and mounted to the tower. Still need to fins another pair of speakers
Attached Images
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:00 AM.