Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Upholstery

Reply
 
Thread Tools Display Modes
  #1  
Old 07-03-2013, 02:28 AM
WalloonPS190 WalloonPS190 is offline
TT Newbie
 
Join Date: Aug 2011
Boat: 2001 ProStar 190 EVO, LTR 330
Location: Midwest
Posts: 6
'01 PS190- bolts have detached/unglued from top of throttle panel

I did some searching but only found references to throttle panels which have holes of some sort clear through the panel. On my '01 PS190 EVO, the bolts have a flat, thin head with holes in it, which is (was) glued to the inside of the panel. There are no holes through the top of the panel itself. The other day I noticed the panel sort of flopping in and out, and determined that the front two (of the three) bolts had broken off of the glue. I am grinding the remaining bits of glue ground off of the loose bolt heads. Wondering if I should try grinding or breaking the large "dabs" of glue off the panel, and reattach the bolts with some sort of epoxy? Any special type? All advice much appreciated.
__________________
__________________________
2001 ProStar 190 EVO, LTR 330
Reply With Quote
  #2  
Old 07-03-2013, 09:48 AM
agua4fun's Avatar
agua4fun agua4fun is offline
TT Enthusiast
 
Join Date: Jun 2005
Boat: Prostar 190 Sammy Duvall
Location: Toledo, Ohio
Posts: 332
Same thing happened to me a few years back. I ended up just predrilling and using 3 stainless screws to hold it down. Its not as pretty, but not too bad looking. it also made it way easier to service parts on the panel.
I tried to upload a picture, but its not letting me today for sone reason.
Reply With Quote
  #3  
Old 07-03-2013, 06:11 PM
WalloonPS190 WalloonPS190 is offline
TT Newbie
 
Join Date: Aug 2011
Boat: 2001 ProStar 190 EVO, LTR 330
Location: Midwest
Posts: 6
Thanks agua. Thought about that but maybe not quite ready, lol. The glue did apparently last 12 years. Maybe have been busted by an aggressive little kid playing with the controls.
__________________
__________________________
2001 ProStar 190 EVO, LTR 330
Reply With Quote
  #4  
Old 07-04-2013, 01:37 PM
catamount catamount is offline
TT Enthusiast
 
Join Date: Feb 2012
Boat: 1987 ProStar 190
Location: Vermont
Posts: 420
I think a 2-part epoxy is definitely your best bet here. Just made sure to put the panel back in place while it sets up so you're sure that the bolts are aligned with their corresponding holes.
Reply With Quote
  #5  
Old 07-07-2013, 11:23 PM
WalloonPS190 WalloonPS190 is offline
TT Newbie
 
Join Date: Aug 2011
Boat: 2001 ProStar 190 EVO, LTR 330
Location: Midwest
Posts: 6
Thanks. I used JB Weld. Success for now it seems. It's sure a huge pain in the a$$ to get those washers and wingnuts on from the back, esp. the middle and front ones. Tried unsuccessfully to completely remove the panel from the boat, wasn't confident enough to disassemble throttle control far enough to achieve that, oh well.
__________________
__________________________
2001 ProStar 190 EVO, LTR 330
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:46 AM.