Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Audio/Stereo

Reply
 
Thread Tools Display Modes
  #1  
Old 05-02-2013, 01:57 PM
racrowe racrowe is offline
TT Newbie
 
Join Date: May 2012
Boat: 2001 mastercraft x30
Location: midwest
Posts: 24
Wetsounds xs-65 in stock 2003 x-2 tower cans

So my buddy us having trouble with putting the xs65 coaxial speakers in his stock tower speaker cans. The boat is a 2002 x2. They work fine but when we put them in the can they ground and cut out. We tried taping the posts on the speaker but that isn't working. Any other ideas that we can try in order to make the speakers stop grounding. I was thinking about buying a thin rubber sheet and lining the inside of the can with it then putting the speakers in. Any help is much appreciated and I hope someone has come up with a solution for this!
Reply With Quote
  #2  
Old 05-02-2013, 09:26 PM
EarmarkMarine's Avatar
EarmarkMarine EarmarkMarine is offline
MC Fanatic
 
Join Date: Aug 2010
Boat: TBD
Location: Dallas, TX
Posts: 518
I would get out a machinist flat file or power Dremmel to place a concealed flat indentation in the pod mounting plate to provide space for the terminals and braided leads to clear.

David
__________________
Earmark Marine
www.earmarkmarine.com
Reply With Quote
  #3  
Old 05-03-2013, 04:57 PM
jigster's Avatar
jigster jigster is offline
TT Regular
 
Join Date: Nov 2011
Boat: mastercraft x-10
Location: southeast
Posts: 71
When i put them in mine i notched out the cans as David mentioned, plus i bent down the terminals flat, used insulated connectors, and put a few layers of electrical tape on the inside of the can. Never had an issue.

-jason
Reply With Quote
Reply

Tags
audio, boat, speakers, stereo, tower speakers

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:42 PM.