Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

Reply
 
Thread Tools Display Modes
  #1  
Old 03-30-2012, 11:12 PM
seth25 seth25 is offline
TT Enthusiast
 
Join Date: Mar 2010
Boat: 2005 X45
Location: Rocky Mtns.
Posts: 216
Calibrating Lake Temp Sensor?

04 X30 water temp is reading about 10 degrees low. Is there a way to calibrate?

Thanks
Reply With Quote
  #2  
Old 03-30-2012, 11:42 PM
93Prostar190's Avatar
93Prostar190 93Prostar190 is offline
MC Devotee
 
Join Date: Apr 2005
Boat: 2008 Prostar 214, MCX, Mini-Tower
Location: Central OH
Posts: 1,466
I want know too! Except mine says the water is much warmer .....2008 in my case.
__________________
Keep a tight line, and a smile on your face. Peace out.
2008 Prostar 214 MCX
Previous 93 Prostar 190 1.5:1 GT40

"Left Foot Forward and preferring girls."
Reply With Quote
  #3  
Old 03-30-2012, 11:51 PM
seth25 seth25 is offline
TT Enthusiast
 
Join Date: Mar 2010
Boat: 2005 X45
Location: Rocky Mtns.
Posts: 216
http://www.mastercraft.com/teamtalk/...p/t-36992.html

Just found this. Looks like no real way to calibrate. Mine is readin 40 degrees.
Reply With Quote
  #4  
Old 04-01-2012, 09:59 PM
WTRSK1R's Avatar
WTRSK1R WTRSK1R is offline
MC Fanatic
 
Join Date: Sep 2004
Boat: 2004 MasterCraft ProStar 197
Location: Wisconsin
Posts: 863
If I remember correctly, 40 degrees is what it reads when the pickup is disconnected.
__________________
A positive attitude may not solve all your problems, but it will annoy enough people to make it worthwhile



2004 Prostar 197 - Red on White

350 TBI, Perfect Pass, Heater, Shower and a whole lot of fun!
Reply With Quote
  #5  
Old 04-01-2012, 10:02 PM
WTRSK1R's Avatar
WTRSK1R WTRSK1R is offline
MC Fanatic
 
Join Date: Sep 2004
Boat: 2004 MasterCraft ProStar 197
Location: Wisconsin
Posts: 863
One other thing, mine was about 5 degrees low and afetr tightening all the ground connections on a ground bus under the dash near the steering wheel it is now within about 1 degree of a meat thermometer on the lake surface.
__________________
A positive attitude may not solve all your problems, but it will annoy enough people to make it worthwhile



2004 Prostar 197 - Red on White

350 TBI, Perfect Pass, Heater, Shower and a whole lot of fun!
Reply With Quote
  #6  
Old 04-02-2012, 08:34 AM
willyt's Avatar
willyt willyt is offline
MC Devotee
 
Join Date: May 2009
Boat: ER xstar
Location: high in the middle and round on both ends
Posts: 1,844
Quote:
Originally Posted by 93Prostar190 View Post
I want know too! Except mine says the water is much warmer .....2008 in my case.
Then you really have no excuse for why I didn't see you at oshay yesterday
Reply With Quote
  #7  
Old 04-02-2012, 11:03 AM
93Prostar190's Avatar
93Prostar190 93Prostar190 is offline
MC Devotee
 
Join Date: Apr 2005
Boat: 2008 Prostar 214, MCX, Mini-Tower
Location: Central OH
Posts: 1,466
Quote:
Originally Posted by willyt View Post
Then you really have no excuse for why I didn't see you at oshay yesterday
Did you just hi-jack a thread to pick on me not being at the lake? ..... dude I will be driving you one day and there will be some speed control issues with the cruise control ....

Peace.
__________________
Keep a tight line, and a smile on your face. Peace out.
2008 Prostar 214 MCX
Previous 93 Prostar 190 1.5:1 GT40

"Left Foot Forward and preferring girls."
Reply With Quote
  #8  
Old 06-18-2013, 07:50 PM
musicmd's Avatar
musicmd musicmd is offline
TT Enthusiast
 
Join Date: May 2012
Boat: 2004 Mastercraft X-10
Location: Midwest
Posts: 113
I'm curious about my lake temp sensor. I have a 2004 X-10 and the lake temp is stuck on 95 degrees. Is this a result of a short somewhere or a faulty sensor?
__________________
2004 X-10

186,000 miles per second - - - not just a good idea, it's the law.
Reply With Quote
  #9  
Old 07-01-2013, 08:59 AM
musicmd's Avatar
musicmd musicmd is offline
TT Enthusiast
 
Join Date: May 2012
Boat: 2004 Mastercraft X-10
Location: Midwest
Posts: 113
Strangely enough, yesterday the water temp was 74-75 degrees, which fits the local measurements. Whatever was causing the earlier problem is now gone (at least for now.)
Reply With Quote
  #10  
Old 08-24-2014, 09:46 AM
JBec JBec is offline
TT Newbie
 
Join Date: Aug 2014
Boat: X14V, 2012, 5.7 OPS
Location: East Coast
Posts: 1
Quote:
Originally Posted by seth25 View Post
04 X30 water temp is reading about 10 degrees low. Is there a way to calibrate?

Thanks
Hi, did you manage to resolve. My 2102 X14V just did the same thing, was working fine but suddenly shows 10 C while water temp. is 20 C. Also my speedo calibration is gone and I can't access the setup menu. Any experience on how to fix this welcome. Thanks.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:20 PM.