Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 02-10-2009, 03:31 PM
CODY_YARBER07's Avatar
CODY_YARBER07 CODY_YARBER07 is offline
TT Regular
 
Join Date: Aug 2005
Boat: 1983 Mastercraft 19 Skiier Stars and Stripes
Location: East
Posts: 88
Send a message via MSN to CODY_YARBER07
Help Wiring Wetsounds Speakers

I bought two Wetsounds Pro 80's and a Cadence TXA-6004 amplifier. I don't know much at all about resistance and such but I am learning. The Pro 80's are 200 Watts RMS and are 4 OHMS. I don't really know what that means other than 4 OHMS is the resistance of the speakers and that I probably need an amp that supports this. The Cadence amp is as follows. 150 x 4 (at 4 Ohms), 300 x 4 (at 2 Ohms), and 600 x 2 (Bridged at 4 Ohms). I know that seems like alot of power for those two speakers but I would like to use this amp for more than just those two speakers if possible. I plan on having a sub and 4 cockpit speakers as well and I would like to hook as much as I can to this amp. I don't know much (if anything) about the difference in series and parallel wiring. I guess what I am really asking is, what is the best way to wire these speakers to this amp. Any help would be GREATLY appreciated. Thanks!!! -Cody
__________________
1983 Mastercraft Stars and Stripes
351 With Powerslot
Reply With Quote
  #2  
Old 02-10-2009, 03:40 PM
brucemac's Avatar
brucemac brucemac is offline
MC Devotee
 
Join Date: Feb 2008
Boat: 2003 Mastercraft X-2 MCX
Location: Pacific Northwest
Posts: 2,414
I could be wrong, but it seems like you really only have one option which is 150x2@4ohms. You don't want to run them at 600x2 and since you only have 1 pair, you're not going to get down to 2-ohm load. They should sound good at 150 a piece. 200W is the recommended RMS rating, but I've done a a lot of reading on it and talked with folks who think they sound great with 150. Post back when you get it hooked up and let us know how they sound. Mine come tomorrow and I can't wait.
__________________
íViva 205v!

2003 X-2 MCX
Reply With Quote
  #3  
Old 02-10-2009, 03:47 PM
CODY_YARBER07's Avatar
CODY_YARBER07 CODY_YARBER07 is offline
TT Regular
 
Join Date: Aug 2005
Boat: 1983 Mastercraft 19 Skiier Stars and Stripes
Location: East
Posts: 88
Send a message via MSN to CODY_YARBER07
Couldn't I hook them up at 600x2 and just use one of the channels?
__________________
1983 Mastercraft Stars and Stripes
351 With Powerslot
Reply With Quote
  #4  
Old 02-10-2009, 03:51 PM
brucemac's Avatar
brucemac brucemac is offline
MC Devotee
 
Join Date: Feb 2008
Boat: 2003 Mastercraft X-2 MCX
Location: Pacific Northwest
Posts: 2,414
i'd email westsounds, but peak RMS is 400 on the pro 80's. granted it's better to be overpowered than underpowered, but i would think 600x2 would not be ideal. if you run them 150x2@4-ohms, you still have 2-channels left on your amp, which is what you said you were hoping for. i am not certain, but i also think that cadence amp may be a little under rated in terms watts.
__________________
íViva 205v!

2003 X-2 MCX
Reply With Quote
  #5  
Old 02-10-2009, 03:55 PM
brucemac's Avatar
brucemac brucemac is offline
MC Devotee
 
Join Date: Feb 2008
Boat: 2003 Mastercraft X-2 MCX
Location: Pacific Northwest
Posts: 2,414
what you should find out from cadence is, if you can use (2) channels 150x2@4 and then bridge channels 3&4 for 600 to a sub. that imo would be ideal. if you're going to run a sub, inboats and tower speakers, imo you need 2 amps.

did you buy that cadence already? you should also be warned some of those had issues with overheating. i don't know the hole story, but i know i ran accross it in the BU forums when i was reading about amps and wetsounds. rumor has it, that's why they had them for sale on their site for b-stock. they redisned the heatsink fins and a circuit iircc.
__________________
íViva 205v!

2003 X-2 MCX
Reply With Quote
  #6  
Old 02-10-2009, 03:56 PM
CODY_YARBER07's Avatar
CODY_YARBER07 CODY_YARBER07 is offline
TT Regular
 
Join Date: Aug 2005
Boat: 1983 Mastercraft 19 Skiier Stars and Stripes
Location: East
Posts: 88
Send a message via MSN to CODY_YARBER07
I wasn't clear in what I meant. I don't know if what I am talking about is even possible but if we have 1200 watts to work (4 channels bridged into two 600 watt channels) with when its bridged then cant I take one of the the bridged channels and run both Wetsounds speakers then use the other bridged 600 watt channel for something else. I haven't finalized the deal on the amp yet so if it won't work then I won't buy it. Like you said, I'd rather overpower than underpower.
__________________
1983 Mastercraft Stars and Stripes
351 With Powerslot
Reply With Quote
  #7  
Old 02-10-2009, 03:57 PM
CODY_YARBER07's Avatar
CODY_YARBER07 CODY_YARBER07 is offline
TT Regular
 
Join Date: Aug 2005
Boat: 1983 Mastercraft 19 Skiier Stars and Stripes
Location: East
Posts: 88
Send a message via MSN to CODY_YARBER07
Yeah I read about them overheating. Apparently it was just a bad batch of amps with the wrong heat sinks. I have an infinity 4 channel to run my cockpit speakers if I need it.
__________________
1983 Mastercraft Stars and Stripes
351 With Powerslot
Reply With Quote
  #8  
Old 02-10-2009, 04:06 PM
brucemac's Avatar
brucemac brucemac is offline
MC Devotee
 
Join Date: Feb 2008
Boat: 2003 Mastercraft X-2 MCX
Location: Pacific Northwest
Posts: 2,414
no, that wouldn't work. you can't run stereo off of 1-channel...

stereo requires a left and right, or 2-channels. bridging 1-channel requires two channels, so stereo bridged requires 4-channels. make sense?

like i said, imo, your best bet is to do 150x2@4 and 600x1@4, that would require a second amp for your inboats.

you could also run, your inboats at 2-ohm (assuming 4 total) which would give you 150W to each speaker and then you could do 600x1 to the sub and buy a new amp for the 80's, something like a wetsounds Syn2 or an alpine pdx series would be my suggestion.

like i said, i think you'll be pleasantly surprised with 150W x 2 on the 80's
__________________
íViva 205v!

2003 X-2 MCX
Reply With Quote
  #9  
Old 02-10-2009, 04:09 PM
CODY_YARBER07's Avatar
CODY_YARBER07 CODY_YARBER07 is offline
TT Regular
 
Join Date: Aug 2005
Boat: 1983 Mastercraft 19 Skiier Stars and Stripes
Location: East
Posts: 88
Send a message via MSN to CODY_YARBER07
Alright. Thank you!
__________________
1983 Mastercraft Stars and Stripes
351 With Powerslot
Reply With Quote
  #10  
Old 02-10-2009, 04:24 PM
brucemac's Avatar
brucemac brucemac is offline
MC Devotee
 
Join Date: Feb 2008
Boat: 2003 Mastercraft X-2 MCX
Location: Pacific Northwest
Posts: 2,414
sure thing. good luck and let us know how it turns out.
__________________
íViva 205v!

2003 X-2 MCX
Reply With Quote
Reply

Tags
audio, ohms, speakers, wetsounds, wiring

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:34 AM.