Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 08-12-2008, 09:55 PM
Flamin'X-1 Flamin'X-1 is offline
TT Newbie
 
Join Date: Jul 2008
Boat: Mastercraft, X-1, 2006, Indmar 315
Location: Southeast
Posts: 15
X-1 Ballast - Need Upgrade

I have an '06 X-1 with the factory two rear hard ballast tanks. When I ride behind it I can barely tell that I have a wake. It washes over every time before I jump. It really sucks. I know that I need more weight, but I had the boat full of 9 people and still my wake was washing over. This boat should be throwing a nice wake, but I really need some help. Could someone please HELP?!?
Reply With Quote
  #2  
Old 08-12-2008, 10:02 PM
'02xrider '02xrider is offline
TT Enthusiast
 
Join Date: Jul 2005
Boat: '02 X-Star
Location: West Side
Posts: 140
The X-1 loves weight up front!!!
Reply With Quote
  #3  
Old 08-12-2008, 10:11 PM
Flamin'X-1 Flamin'X-1 is offline
TT Newbie
 
Join Date: Jul 2008
Boat: Mastercraft, X-1, 2006, Indmar 315
Location: Southeast
Posts: 15
Well does anyone have any ideas of upgrades for ballast or how to arrange weight? I really need to get my wake right!
Reply With Quote
  #4  
Old 08-12-2008, 10:22 PM
TMCNo1 TMCNo1 is offline
MC Hero
 
Join Date: Jul 2005
Boat: Gone
Location: Gone
Posts: 22,134
Was this before or after you lost your platform?
__________________
Charter Member Number 1

Quote: 2RLAKE,
At some point in time people need to wake up, remove their cranial intrusion into their own rectal areas, and take responsibility for their own actions.




Reply With Quote
  #5  
Old 08-12-2008, 10:54 PM
Flamin'X-1 Flamin'X-1 is offline
TT Newbie
 
Join Date: Jul 2008
Boat: Mastercraft, X-1, 2006, Indmar 315
Location: Southeast
Posts: 15
Losing my platform has not affected this! The poor wake performance has been happening since I have owned the boat.
Reply With Quote
  #6  
Old 08-12-2008, 11:02 PM
Jim@BAWS's Avatar
Jim@BAWS Jim@BAWS is offline
MC Addict
 
Join Date: Aug 2004
Boat: 1996 PS 190 LT-1/Powerslot
Location: Land O Lakes. FL
Posts: 5,123
Quote:
Originally Posted by Flamin'X-1 View Post
Losing my platform has not affected this! The poor wake performance has been happening since I have owned the boat.

Poor wake performance for 3 + years? I have to call you out on that one !!! Sorry. The X-1, prior X-2 Old X-Star has one of the best wakes that the industry has ever made. Why do you think it has been around so long and continues to be produced by MC?

To beef up your wake add another 400 + LBS in the storage lockers in the rear. Add a TUBE SAC in the ski storage locker where the KGB sac would normally go. Be ready to change to another prop

Hope this helps

Jim@BAWS
__________________
James (Jim) Kranendonk Pres-BAWS
Tampa Bay's Exclusive MasterCraft Dealer

www.BAYAREAWATERSPORTS.com
(813) 996-BAWS (2297)
Reply With Quote
  #7  
Old 08-12-2008, 11:05 PM
Flamin'X-1 Flamin'X-1 is offline
TT Newbie
 
Join Date: Jul 2008
Boat: Mastercraft, X-1, 2006, Indmar 315
Location: Southeast
Posts: 15
I bought the boat used 2 months ago. I have not had it for 3 years, so I am just now getting aquainted with it. Why do you say I should be ready to change to another prop?
Reply With Quote
  #8  
Old 08-12-2008, 11:18 PM
mccobmd's Avatar
mccobmd mccobmd is offline
MC Devotee
 
Join Date: Apr 2007
Boat: Mastercraft X1 2006 310HP
Location: Oklahoma
Posts: 1,035
What speed and rope length are you riding? My X1 throws a great wake at 21mph 70 ft rope. It will wash out if you get too slow. I haven't added extra ballast yet but my dealer has been behind everything and said 300 in each side, tube sac in the locker and 200 up front on both sides to wakeboard, 200 front and 300 rear on starbord side to surf. I am curious about the prop as well
Reply With Quote
  #9  
Old 08-12-2008, 11:26 PM
Flamin'X-1 Flamin'X-1 is offline
TT Newbie
 
Join Date: Jul 2008
Boat: Mastercraft, X-1, 2006, Indmar 315
Location: Southeast
Posts: 15
I am riding on 65 ft. rope and being pulled at 23.4mph. I don't know what the problem is.
Reply With Quote
  #10  
Old 08-13-2008, 12:04 AM
tbd01's Avatar
tbd01 tbd01 is offline
TT Enthusiast
 
Join Date: Jul 2006
Boat: 07X1, custom trailer, Rtp1, wetsounds pro 485 and pro 60's
Location: central arkansas
Posts: 123
like mccobmd said, I have 300 extra in the rear lockers, and 400 in the bow, and at 23.3 mph my wake is amazing, so the kids say
Reply With Quote
Reply

Tags
ballast, ballast system, upgrade, wake, x-1

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:55 AM.