View Single Post
  #1  
Old 06-24-2013, 12:54 AM
Mark rsa2au's Avatar
Mark rsa2au Mark rsa2au is offline
TT Enthusiast
 
Join Date: Mar 2013
Boat: Mastercraft X5 2001. 310hp preditor
Location: Australia
Posts: 182
Guages intermittant & revs reduced connected issue?

Hi Guys,

This weekend while out for a ski the guages started failing, firstly both speedo's failed, but came right when I stopped - possable cause debris in the pick ups... but both at the same time? Carried on and then all guages went to zero, and engine reduced revs..... Shut down and restarted, guages back and revs ok. 20 mins later guages all fail except for rev counter but engine runs fine... this used to happen intermittantly but is now happening often.
PS air temp about 43F and water temp about 50F (yes [email protected]#$n cold but better than the alternative.. no ski) All guages now working fine again....?

I have ordered a new temp sender, thermostats & impeller as the rev reduction might be a (false) overheat signal. ( another issue). Will the failed guages cause issues with the engine or can I continue along this line?

Checked all earth connections (ohm resistance measured ok), wire brushed and replaced where necessary, no water in speedo tubes. Could the black box be going and if so could it be intermittant or does it just fail and stop working?

Never in my 20 years (and 6 boats) of watersking have I had such an unreliable boat..... Wife and kids renamed it the Disastercraft.. ( List of other issues too long to list here) Need to change this soon or boat will have to go. Any advise appreciated!
Reply With Quote