View Single Post
  #1  
Old 07-26-2014, 05:09 AM
Olaff's Avatar
Olaff Olaff is offline
MC Fanatic
 
Join Date: Jul 2014
Boat: 2001 Prostar 205V. 1982 S&S Powerslot (sold).
Location: SE Texas
Posts: 860
Antique S&S Bow Bilge doesn't drain

Alright I've had something nagging at me. In my 1982 Stars & Stripes, water that finds its way into the bilge finds its way forward of the pylon mount and into the bow which hapens to be the low spot of the bilge. For some reason Mastercraft decided to mount the bilge pump right under the engine which seems to be high ground in the bilge to me. I have been able to get about 2 gallons of water out of the rear drain plug by lifting the trailer tongue as high as possible so the rudder touches the ground (on my sloped driveway).
I had thought about relocating the pump forward but was concerned about access. So instead I decided to eliminate the low spot.
I did this work in conjunction with reinforcement of my pylon mounts which I am pretty proud of (see 82 S&S Pylon Reinforcement), so the floor forward of the engine was already out.

I started by cutting a "dam" to fit the cross section contour of the hull just forward of my newly reinforced pylon bracket.


I used a 1/2" thick wedi shower waterproofing backer board for this job because they are waterproof, lightweight, mold & mildew resistant, easy to cut, and their sealant/adhesive is a modified urethane that is Mil Spec and used for waterproofing in Amphibious Fighting Vehicles for the USMC
www.wedicorp.com
Attached Images
  

Last edited by Olaff; 07-26-2014 at 05:12 AM. Reason: added a pic
Reply With Quote