View Single Post
  #25  
Old 10-10-2013, 05:47 AM
Mark rsa2au's Avatar
Mark rsa2au Mark rsa2au is offline
TT Enthusiast
 
Join Date: Mar 2013
Boat: Mastercraft X5 2001. 310hp preditor
Location: Australia
Posts: 182
Ok, having run every possable electronic measurment mensioned on this and other forums ( and now the Indmar manual) I believe that all the current sensors on the boat are all within spec.

So far I have replaced both thermostats (origionals so replaced for insurance), the ecm temp sensor (faulty), and the impeller (insurance). The MAP sensor replaced (not sure if it was faulty) the throttle position sensor (bad readings), the Air Idle Screw (broken). This week I replaced the Knock sensor, and its connector as it was throwing a code.

The spark plugs, plug leads, distributer, rotor, and coil lead have all been replaced and firing order checked ok.

This week I replaced the fuel system. Fuel Filter, Walbro fuel pump (67 gallons per hour, and up to 90 psi), intank fuel lines and clamps. Also replaced fuel lines from the tank to the motor, and the return lines. Replaced pressure regulator and had the new injectors (30 hours) cleaned just in case. Installed fuel pressure guage and pressure sits steady at 31 PSI at all revs on the trailer (yes full throttle on water is the only real test).

Also pulled the valve covers off to check for broken valve springs, scored cams etc and can see nothing out of the ordinary. Also compression is steady across all cylinders.

Last thing to do is drain some oil from the motor as I have over filled it during the oil change I did. It's about 3 mm over the high mark on the dipstick.

Will be taking it out to the lake on Saturday for its final test, if it runs perfectly we keep it and I replace the MDC and/ or the guages as they have all sh@t themselves as well. If not.....

I do note that my previous 4 boats ( 2 X Yamaha, Sea Ray and Malibu) required no parts replacement other than normal servicing while I had them. They started easily and ran perfectly for the 3 to 5 years I owned each. None of them ever let me down and they were older than 10 years when I purchased them. I purchased a Mastercraft expecting to have a higher quality & reliability but sadly either due to poor desighn, poor quality, or poor maintainence this has not happened. I hope after testing / repairing / replacing everything possible I might find that legendary Mastercraft quality and reliability.

Ps Thanks to all that have helped so far, I will let you know on Saturday... or look out for the smoke signals....
Reply With Quote