View Single Post
  #6  
Old 08-08-2013, 04:04 PM
skitilldark skitilldark is offline
TT Enthusiast
 
Join Date: Mar 2010
Boat: 2014 X-25 6.2 Ilmore
Location: Southeast
Posts: 518
Okay guys, I need the smartest MC guys on these boards to weigh in on this if possible. It is getting worse but 5 weeks later and still no one can solve it. I say worse because when it first started happening, I could kill the switch, turn it back on and it might be two days before it did it again. Now, it does it within 10 minutes every time. Since I am rapidly losing friends who happen to be riding when the boat goes into limp mode, I've got to come up with a solution. I tried some earlier advice of checking for corrosion between the coil and the ECM, but nothing there. As you can see on the video link, I checked fuel pressure during the event and the psi is normal. The engine surges between 1500 and 2200 rpm during the event. It NEVER clears itself up. Only killing the ignition will make it go away. Throttle position is irrelevant. The cruise control is off. A new occurance is that when I kill the ignition and fire it back up, at least one guage goes dead. Sometimes it is the speedo, sometimes it it temp guage, sometimes it is the oil pressure guage. But mostly it is the speedo or the temp guage. Never the fuel guage or the tach. I have no idea what that could mean but thought I should include it. Notice in the video that the CHECK ENGINE light never comes on during the event.

To clarify the first post, (I always get the LTR and MCX confused), my engine is not an MCX, it is the LTR. And you CANNOT get the boat to experience this anomaly when it is cool. It only happens after the boat has been on a fairly hard run(30-37mph)with varying throttle inputs. The dealer had the boat for three weeks and ran two tankfuls of gas through it trying to make it do this and they could not. I got the boat back and did it within 30 minutes. The ONLY difference between me and the dealer's driving the boat is I always have a skier or tuber, etc and have several people in the boat. They did not. Other than that I can't think of anything I do different that could be triggering the event. PLEASE HELP IF YOU CAN!!!

Here are a couple of videos of the "anomaly";

http://youtu.be/-_ZET4BRR3E

http://youtu.be/4Sp2PPcMjy4
Reply With Quote