View Single Post
  #14  
Old 04-12-2013, 05:31 PM
thatsmrmastercraft's Avatar
thatsmrmastercraft thatsmrmastercraft is offline
MC Master Poster
 
Join Date: Sep 2008
Boat: 1977 Stars & Stripes
Location: St. Paul, MN
Posts: 15,164
Quote:
Originally Posted by Kweisner View Post
On the blower, does the switch light up? If so, check the actual fan inside the blower housing itself. Try to give it a spin with your finger (switch off). When I got my boat last fall, I spent a good bit of time tracing/testing the circuit, only to find that the fan itself had seized from not being used. Once I "broke" the fan free, it worked fine for a while (but ultimately i did replace as the bearing became noisy). Got a replacement for about $30 (mine was a 3" diameter). Good luck and welcome to the forum--great folks here always willing to lend a hand and sometimes a little humor or sarcasm. Oh yeah. . .pix are kind of a big deal here too!
When a bilge pump gets hung up, its usually due to corrosion and time to replace so it works when you need it. Sometimes they will suck in some debris and plug up. Put a garden hose against the pump outlet and give it a little backflush. Sometimes that is all it takes.
__________________
Peter

SPECIAL PRICE
ST205/75R15 KENDA LOADSTAR ON 15X5 WHITE SPOKE WHEEL, BALANCED & DELIVERED - $125 EACH


Tandem Axle Packages Starting at $569 - 4 Aluminum wheels, 4 ST205/75R14 tires, mount & balance.
Single Axle Package Starting at $319 - 2 Aluminum wheels, 2 ST205/75R14 tires, mount & balance.

CARBURETOR REBUILDING - $125 + PARTS
LED lights, Hubs, Spare Tire Carriers, Chrome & Powder Coated Lug Nuts

PM or email me tiresplease@gmail.com
*** FREE DELIVERY ON ALL ORDERS ***
Reply With Quote