View Single Post
  #9  
Old 03-04-2013, 02:46 PM
Dylan's Avatar
Dylan Dylan is offline
TT Enthusiast
 
Join Date: Mar 2010
Boat: 1995 Barefoot 200- Yamaha Pro-v
Location: Southern CA & AZ
Posts: 434
Quote:
Originally Posted by rgardjr1 View Post
I've got a 2006 Maristar 200 SS-which was the salt water version of the X-2 in 2006. The main difference is that mine came with the closed cooled 5.7L Crusader. It sounds like the owners may have retrofitted the closed cooling on the MCX for salt water use? Does the boat have sacrificial anodes? Careful about thinking the billet will polish out. My boat had less than 50 hours of salt water use when I bought it, but those white looking spots probably won't polish out completely. On the speaker cans the salt had eaten through the clear anodizing-pretty much no way to fix that. The tower and board racks do a little better because they are not anodized, but I've spent a bunch of time polishing mine and I still notice where the salt was left to sit (purely asthetic). I bought my 2006 with 48 hours in August of 2008 for $42K-it was a little more loaded than the boat you're looking at. Mine came with the galvanized trailer that I had to replace the actuator on last summer. I'm going to tear into the trailer some more this summer once my boats in the water-salt is really tough on trailers.
I actually read some of your posts when I searched I believe, and I really appreciate your input. It is indeed a retrofitted MCX. I was fully expecting to drive up there and see that bright blue crusader engine.

I definitely see those small white circles, which I believe were water spots. Could that be the annodizing failing?

Also, have you had any of the electronics fail? I ask because that is my biggest concern. My only experience with salt water boats has been sailboats when I was younger, so not really a great source.

This boat was kept out of the water, and never in a slip. Seems like it was hosed off really well. No annodes on the rudder I could see, but other than it was slightly dull, all the underwater gear looked fully functional and not pitted at all. I checked it very carefully. All the fluids looked fresh as well.
Reply With Quote