View Single Post
  #18  
Old 11-17-2012, 10:59 AM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 10,400
Send a message via Skype™ to mikeg205
Quote:
Originally Posted by reftech View Post
I'm thinking the sand is from the bottom of the lake when they let the water level off for owners to do dock work.he never removed the boat from the water so the intake fitting was on the bottom of the lake possibly. I masked the rub rail with standard 3/4 inch 3m tape and that is plastic sheeting from Lowes.the white paper is standard paint masking paper on a roll.the motor also had a cracked block at cylinder 7 and two freeze plugs were out.luckily I already had a motor out of a supra ts6m with 500 hours on it so all I had to do was change over the marinization parts from PCM to indmar off of the original motor.I then put new belts hoses and all new ignition and tune up parts as well as new seal and impeller on the rwp.the tranny had a front seal leak which I replaced also.
Thanks...didn't see the tape right away cuz of the color of the paint. How did you trip plastic...before taping or after taping... have some work to do on my benz..and like the plastic cover idea...I'm a real noob when it comes to restoration..and want to learn more...it's going to be my retirement plan... when I get old I will restore Mastercraft's....
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote