View Single Post
  #9  
Old 10-26-2011, 05:13 PM
Cloaked Cloaked is offline
MC Maniac
 
Join Date: Dec 2004
Boat: MasterCraft
Location: Kingston,TN USA
Posts: 4,602
Upon looking at your picture, do as another poster said and take it to a machine shop, however they will not guarantee any results.

Try soaking the threads with PB Blaster maybe...... then remove the plug(s) if they loosen up....

If you're OK with leaving well enough alone, leave it alone. There is maybe 1 - 2 quarts of water at most (in each). Optionally, open the chamber through removal of the riser (not my first choice) or remove the forward hose at the thermostat housing and pour a 50/50 solution of anti-freeze down into the hose and on into the riser chamber. Drain the remainder of the block (two plugs) and the J-tube plug. Pull the hose from the bottom of the tranny cooler to drain that, and it's a done deal.

Or fill the entire engine with the 50/50 solution until it comes out the exhaust. Another done deal.

.
__________________
93 190
.
Don't be a boot licker
.

Hose picture (internal) http://www.mastercraft.com/teamtalk/...68&postcount=8



Quote:
Originally Posted by Thrall View Post
..Some of you give a whole new meaning to the phrase "another @sshole with a Mastercraft."

RE: Thrall, Welcome to the club....
NEW SKINS in TN... Leading Edge Marine Interior

feedback on a TN company: http://www.mastercraft.com/teamtalk/...ad.php?t=58767

.

Last edited by Cloaked; 10-26-2011 at 05:17 PM.
Reply With Quote