View Single Post
  #10  
Old 09-17-2011, 09:37 PM
bartman's Avatar
bartman bartman is offline
TT Newbie
 
Join Date: Sep 2011
Boat: Mastercraft Prostar 190, 1995, LT-1
Location: Northeast
Posts: 28
Quote:
Originally Posted by ahhudgins View Post
Bartman was the only one who mentioned his temperature being 180 degree or higher. I have the 95 TBI and not the LT-1 but the book says 142 for the TBI and 142/160 for the LT-1. If it were me, I would replace the thermostats or at least take them out and see if the problem goes away with the engine running cold. It is possible that 180+ degrees is just on the boarder line of being too hot.

Several of us with the 95 TBI Maristars have the 142 thermostat and the engine acts up if we try to run the 160 thermostat. The engine will run at 160 degrees but doesn't want restart after it has been shut off.
I looked at the manual I found online for the PS190 and I thought it said normal temp was between 170 and 195. Normal Oil Pressure at idle is between 7 and 30 PSI. In fact, the MC Dealer discouraged replacing the thermostats. Maybe I will replace and see if that helps.

Interestingly, after running at 180 for a while, when you stop, or especially shut off, the temp goes above 180 (but I don't think it goes above 195). It seems like that may be when it starts... I have it scheduled for Monday at the shop to have them put it on the computer to see what exactly the engine is doing and saying. I am thinking that I should do this anyway, since the boat is new to me, to see if I can get this resolved, and to see if there are any other problems looming out there.
Reply With Quote