View Single Post
  #10  
Old 09-07-2010, 07:28 PM
Cloaked Cloaked is offline
MC Maniac
 
Join Date: Dec 2004
Boat: MasterCraft
Location: Kingston,TN USA
Posts: 4,602
Quote:
Originally Posted by DavidMCX30 View Post
Fantastic! Glad to hear that you've solved your issue. I think this type of repair sounds above my skill level, so I'm going to ask my mechanic to take a look. I'll print this thread so he can look at it. Thanks for all your insight. Have fun on the water!
If you can read the wrench size on the side of the wrench, you can do the change-out. Remove 4 bolts (per riser), unscrew three worm-gear clamps, remove the hose(s), install the new hose (easily cut-to-fit), reassemble with a new gasket and anti-seize on the new bolts. Done deal.

Not saying this is an issue with your machine, but the entire cooling system is nothing but simple wrenching.

Good luck and happy boating.

Here's a pic of the new riser gasket and a cleaned surface on the exhaust manifold where the riser / gasket attaches. Easy pickings. There's not much inside of there once it's opened up.


.
Attached Images
 
__________________
93 190
.
Don't be a boot licker
.

Hose picture (internal) http://www.mastercraft.com/teamtalk/...68&postcount=8



Quote:
Originally Posted by Thrall View Post
..Some of you give a whole new meaning to the phrase "another @sshole with a Mastercraft."

RE: Thrall, Welcome to the club....
NEW SKINS in TN... Leading Edge Marine Interior

feedback on a TN company: http://www.mastercraft.com/teamtalk/...ad.php?t=58767

.

Last edited by Cloaked; 09-07-2010 at 07:36 PM.
Reply With Quote