Go Back   TeamTalk > Search Forums

Showing results 1 to 4 of 4
Search took 0.00 seconds.
Search: Posts Made By: benvickers38
Forum: Audio/Stereo 07-10-2013, 09:42 AM
Replies: 8
Views: 1,762
Posted By benvickers38
Sorry, I would post a pic but I had to sell my...

Sorry, I would post a pic but I had to sell my boat (USAF stationed over seas). It was just under the large plastic cover on the top of the engine. Sorry I can't help more.

JimN wants me to delete...
Forum: Audio/Stereo 07-01-2013, 11:10 PM
Replies: 8
Views: 1,762
Posted By benvickers38
Fixed it!!

Hey all... I stumbled on to the solution for the problem when I was changing my spark plugs. Under the plastic top cover on the motor was a random plug just unplugged. Plugged it back in and I was...
Forum: Engine / Drive Train 08-13-2012, 02:22 AM
Replies: 3
Views: 1,290
Posted By benvickers38
Cool 'Check Engine' under power

Help! My stereo cuts off and the "CHK ENG" warning comes on when I'm at higher than idle power. What could that be?

2007 X-Star SS, 6.0L Crusader, WetSounds tower speakers w/ eBay-bought amp. ...
Forum: Audio/Stereo 07-26-2012, 11:43 AM
Replies: 8
Views: 1,762
Posted By benvickers38
Stereo cutting off w/ 'Chk Eng' Message??

Hi, I haven't seen this problem anywhere on the forum so I'm starting a new thread:

I have an 07 X Star SS with the Crusader 6.0 engine. As the engine is in gear and usually under power/high RPMs,...
Showing results 1 to 4 of 4

 

All times are GMT -4. The time now is 06:03 PM.