Go Back   TeamTalk > Search Forums

Showing results 1 to 12 of 12
Search took 0.00 seconds.
Search: Posts Made By: curry154
Forum: Engine / Drive Train 08-12-2011, 01:42 PM
Replies: 1
Views: 438
Posted By curry154
1999 x star transmission noise

have a 99 x star v-drive with a hurth transmission and I have been told the trans noise at idle is a planetary gear at the top of the transmission is there any way to reduce the noise or is there...
Forum: Engine / Drive Train 06-03-2010, 07:46 AM
Replies: 1
Views: 409
Posted By curry154
99xstar ,found The Problem

Had been posting about a problem with my "99 xstar would not accelerate"just found about an inch of water in the bottom of the fuel tank and when you go to take off all the water would end up at the...
Forum: Electrical 05-29-2010, 11:40 AM
Replies: 1
Views: 403
Posted By curry154
99 Xstar Running Problem

I have a issue with the engine not having any power when it gets to temp, I have replaced the fuel pump and have 40psi of pressure when running I also have very good spark ,,seems to be something...
Forum: Engine / Drive Train 05-27-2010, 05:35 PM
Replies: 0
Views: 277
Posted By curry154
99 Xstar Wont Accelerate

posted a few days ago about my 99 xstar will not accelerate when the engine is up to temp. have just replaced the fuel pump and filter but did not change anything ,,i checked spark after it started...
Forum: Engine / Drive Train 05-26-2010, 12:21 PM
Replies: 3
Views: 500
Posted By curry154
the boat seems to run fine for about 1 minute,...

the boat seems to run fine for about 1 minute, you can accelerate in gear and out of gear but after that it starts loosing power in gear ,but out of gear you can rev the engine up , i did check the...
Forum: Engine / Drive Train 05-26-2010, 09:30 AM
Replies: 3
Views: 500
Posted By curry154
99 xstar idles but wont accelerate

looking for some input ,have a 99 xstar with the 350 ,the boat has no power to accelerate ,i pulled the fuel pump and the pump seems to be working ,,not sure about the fuel pressure ,i went ahead and...
Forum: Engine / Drive Train 05-02-2008, 02:17 PM
Replies: 1
Views: 456
Posted By curry154
99xstar drive shaft question

i am pulling a 630iv hurth transmission out of a 1999 xstar and need some advice on how or what to do to get the drive shaft out of the transmission / do you unbolt it and pull it out enough to...
Forum: General Discussion 05-01-2008, 05:24 PM
Replies: 4
Views: 646
Posted By curry154
thanks again ole miss , i did check that first /...

thanks again ole miss , i did check that first / along w/fluid level . but im afraid eather something internal inside trans went or im hoping just a flex plate eather way trans has to come out , i...
Forum: General Discussion 05-01-2008, 01:49 PM
Replies: 4
Views: 646
Posted By curry154
thanks for the advice , sounds right to me , im...

thanks for the advice , sounds right to me , im going to pull the v-drive on saturday and check
Forum: Engine / Drive Train 04-30-2008, 06:54 PM
Replies: 0
Views: 371
Posted By curry154
99 xstar hurth transmission problem

have a 99 xstar .boat has been working fine till yesterday , engine starts but no forward or rev. i did have some clattering noise for a while at idle in gear but went away on slight acceleration ,...
Forum: General Discussion 04-30-2008, 05:45 PM
Replies: 4
Views: 646
Posted By curry154
99 Hurth Transmission Question

have 99 xstar that one day i had forward and rev. the next day , nothing,,prop wont move in eather gear , the trans is a hurth 630iv and im hearing some talk of a possible broken flex plate ,,...
Forum: General Discussion 04-30-2008, 10:11 AM
Replies: 1
Views: 501
Posted By curry154
1999 x-star transmission problem

i have a 99 x-star with v-hurst tranmission , this winter i noticed slightly milkey trans fluid , i sucked the trans out 3 times and have not seen any water in fluid so far this year and the...
Showing results 1 to 12 of 12

 

All times are GMT -4. The time now is 11:29 PM.