Go Back   TeamTalk > Search Forums

Showing results 1 to 7 of 7
Search took 0.00 seconds.
Search: Posts Made By: rrskier
Forum: General / Other 10-10-2011, 08:57 PM
Replies: 18
Views: 4,330
Posted By rrskier
Anyone out there have a non blown out baffle off...

Anyone out there have a non blown out baffle off a 2007? I hear its quite a job to break loose the 3M sealant from the transom, a job I only want to do once.
Forum: General / Other 09-22-2011, 01:44 AM
Replies: 18
Views: 4,330
Posted By rrskier
exhaust Baffle snaps out of pipe!

Tonight while skiing I noticed my 07 X7 sounded louder than normal. Back at the dock I stuck my hand up the exhaust outlet and no baffle on starboard. About six months after the boat went out of...
Forum: Engine / Drive Train 06-07-2011, 01:54 AM
Replies: 19
Views: 3,390
Posted By rrskier
The comments by oumiller28 asked the question of...

The comments by oumiller28 asked the question of manually resetting the alarm. My experience is on my 2007 X7 MCX. Yes, this can be done. Last year while trying to be careful I removed my spark...
Forum: Underwater Running Gear 06-06-2011, 01:43 AM
Replies: 5
Views: 690
Posted By rrskier
MC Splined Prop

I have a prop for sale on Ski-It-Again, Post ID SIA15372. The prop came as a spare on a 2007 X7. I run a larger 3 bladed prop for skiing.
Forum: Engine / Drive Train 06-01-2010, 12:29 AM
Replies: 8
Views: 3,483
Posted By rrskier
Boat was started, run to temp of 160 degrees then...

Boat was started, run to temp of 160 degrees then cooled to 100 degrees. Procedure was repeated three times. Upon fourth startup buzzer did not sound!!!
Would the error code which originally...
Forum: Engine / Drive Train 05-26-2010, 03:23 AM
Replies: 8
Views: 3,483
Posted By rrskier
The battery was on a good charger for appx. 20...

The battery was on a good charger for appx. 20 hrs and was fully charged. After running the boat to temp of 160 I disconnected the battery thinking the system might reset. But unfortunately the...
Forum: Engine / Drive Train 05-26-2010, 01:42 AM
Replies: 8
Views: 3,483
Posted By rrskier
Check Engine and Buzzer

Just brought out 07 X7 MCX and de-winterized. Everything went as normal except after 15 seconds of running on trailer the engine buzzer sounds and CHK ENG shows on tach display. 3/4ths tank of gas,...
Showing results 1 to 7 of 7

 

All times are GMT -4. The time now is 07:41 AM.