Go Back   TeamTalk > Search Forums

Showing results 1 to 7 of 7
Search took 0.00 seconds.
Search: Posts Made By: 01MCX30
Forum: Trailers 07-15-2011, 02:28 PM
Replies: 3
Views: 694
Posted By 01MCX30
Oil Bath or Bearing Buddies?

I recently purchased a 2001 X30 with a 2002 tandem-axle MC trailer. I discovered that it has one hub with a Bearing Buddie and three hubs that are still using the original Oil Bath. Is there any...
Forum: Engine / Drive Train 07-15-2011, 02:24 PM
Replies: 5
Views: 2,050
Posted By 01MCX30
This was exactly the cause of all my issues. ...

This was exactly the cause of all my issues. Took the alternator to a local rebuilder and he told me I had an old Prestolite 55 amp and that it was old technology. He upgraded me to an 80 amp and...
Forum: Electrical 07-10-2011, 10:18 PM
Replies: 2
Views: 312
Posted By 01MCX30
Alternator Recommendation?

I have a 2001 X30 and want to replace the stock alternator (currently shot) with one with a higher output amperage due to the stereo system in this boat. Can anyone give me a recommendation with a...
Forum: Engine / Drive Train 07-10-2011, 09:59 PM
Replies: 8
Views: 514
Posted By 01MCX30
I will check that out East TX...Thanks!

I will check that out East TX...Thanks!
Forum: Engine / Drive Train 07-10-2011, 09:57 PM
Replies: 8
Views: 514
Posted By 01MCX30
Thank you guys! I appreciate all of the support...

Thank you guys! I appreciate all of the support for a new MC owner. I ended up replacing both batteries and finally got the PP tests to function correctly. It checks out as okay. I got the...
Forum: Engine / Drive Train 07-09-2011, 05:54 AM
Replies: 8
Views: 514
Posted By 01MCX30
PerfectPass the Issue?

I posted recently about my 2001 X30 sputtering out after about 10 minutes on the lake and thinking it might be fuel related. I've checked everything related to fuel and all checks out okay. Someone...
Forum: Engine / Drive Train 07-07-2011, 12:56 PM
Replies: 5
Views: 2,050
Posted By 01MCX30
2001 X30 Loss of Power - Safe Mode?

Just bought a 2001 MC X30 with the MX LTR 5.7L engine. We took it out yesterday and it ran great for about 3-4 hours. Then it seemed as if some sort of Guardian Mode kicked in and would not let me...
Showing results 1 to 7 of 7

 

All times are GMT -4. The time now is 06:10 PM.